summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-12 13:38:06 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-12 13:38:28 -0400
commit9a4b961281e627b8bb56bca6509ed25b7420bc81 (patch)
treecdaafaac2ff1acaf65c66d1296e82e837f20a654 /dev-php/PEAR-HTTP_Header
parentdev-python/pyparsing: version bump to 2.1.5 (diff)
downloadgentoo-9a4b961281e627b8bb56bca6509ed25b7420bc81.tar.gz
gentoo-9a4b961281e627b8bb56bca6509ed25b7420bc81.tar.bz2
gentoo-9a4b961281e627b8bb56bca6509ed25b7420bc81.zip
dev-php/PEAR-HTTP_Header: new EAPI=6 revision sans the PEAR eclass.
We have a lot of trouble with our php-pear-* eclasses. Many of the PEAR packages (including PEAR-HTTP_Header) can be installed in only a few lines, in which case it seems smarter to skip the eclass altogether. This new revision does so, and lets us jump to EAPI=6. Gentoo-Bug: 576432 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php/PEAR-HTTP_Header')
-rw-r--r--dev-php/PEAR-HTTP_Header/PEAR-HTTP_Header-1.2.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_Header/PEAR-HTTP_Header-1.2.1-r2.ebuild b/dev-php/PEAR-HTTP_Header/PEAR-HTTP_Header-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..283c245d6c22
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Header/PEAR-HTTP_Header-1.2.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_P="${P/PEAR-/}"
+
+DESCRIPTION="Handle and modify HTTP headers and status codes in PHP"
+HOMEPAGE="http://pear.php.net/package/HTTP_Header"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-HTTP"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r HTTP
+}