summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-11-28 12:54:30 -0500
committerBrian Evans <grknight@gentoo.org>2016-11-28 12:55:20 -0500
commit396f0b7c54fc26cb2b18f21395c2a7402a96d08e (patch)
treeeb083c7debed352f47e960ce3887c333cb244b73 /dev-php/igbinary
parentdev-php/pecl-dbx: Drop old (diff)
downloadgentoo-396f0b7c54fc26cb2b18f21395c2a7402a96d08e.tar.gz
gentoo-396f0b7c54fc26cb2b18f21395c2a7402a96d08e.tar.bz2
gentoo-396f0b7c54fc26cb2b18f21395c2a7402a96d08e.zip
dev-php/igbinary: Version bump including PHP 7 support
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/igbinary')
-rw-r--r--dev-php/igbinary/Manifest1
-rw-r--r--dev-php/igbinary/igbinary-2.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/igbinary/Manifest b/dev-php/igbinary/Manifest
index 2d948224dc1c..f9e790e11e2b 100644
--- a/dev-php/igbinary/Manifest
+++ b/dev-php/igbinary/Manifest
@@ -1 +1,2 @@
DIST igbinary-1.2.1-r1.tar.gz 143092 SHA256 f71a2e085669ed915740b29f55b6a81e30bae52215d041938afb9212e6bafc27 SHA512 5e69831606cfe47db2ae2b2200bd8bcfce42db32599a2a58cf23238d88896a2ef79baf16e78b3aaefb8725f8fdd7b815470e2d314ba14ea05f33be547da31777 WHIRLPOOL f7eb5d28b536bd1d2b0565f3e8541cbdb39edd2f5130bd041f0d75cc8218edeaa8719ebaea4d8ddf372172df9863d9d72a12dd8fc09c3653418b49e26d0e2f61
+DIST igbinary-2.0.0.tar.gz 176546 SHA256 864785bc759f7e249534b7834d7762915851242e57a24ee9e13cac27d2a25b8e SHA512 8cd46e70ca2dfd441fa99c29a458923615fc25aab11a0d4e33770505495dd8fbd0071f9c4822b22c941b1240c609be549b1cb625b76b933b0dec7acc7f792122 WHIRLPOOL 2868676b7beb25aac244fb88a7ae48b6983ff605f9a1f12997ecb23e13a1513a53b59380a72bbf8d08075a9905dc74df527e6363bb1e81c139c23ac1018a22cb
diff --git a/dev-php/igbinary/igbinary-2.0.0.ebuild b/dev-php/igbinary/igbinary-2.0.0.ebuild
new file mode 100644
index 000000000000..e4d85b2fdfcc
--- /dev/null
+++ b/dev-php/igbinary/igbinary-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( ChangeLog NEWS README.md)
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+
+USE_PHP="php5-6 php7-0"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""