summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-02-21 12:59:02 -0500
committerBrian Evans <grknight@gentoo.org>2020-02-21 12:59:02 -0500
commit1a6f847f29b1a626a25c8d531f9bd1a0ac8a67c2 (patch)
tree83e1d8f7a8863530b320e914ef48d00f8dc8bae4 /dev-php/maxmind-db-reader
parentdev-php/pecl-stomp: Drop old (diff)
downloadgentoo-1a6f847f29b1a626a25c8d531f9bd1a0ac8a67c2.tar.gz
gentoo-1a6f847f29b1a626a25c8d531f9bd1a0ac8a67c2.tar.bz2
gentoo-1a6f847f29b1a626a25c8d531f9bd1a0ac8a67c2.zip
dev-php/maxmind-db-reader: Version bump for 1.6.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/maxmind-db-reader')
-rw-r--r--dev-php/maxmind-db-reader/Manifest1
-rw-r--r--dev-php/maxmind-db-reader/maxmind-db-reader-1.6.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-php/maxmind-db-reader/Manifest b/dev-php/maxmind-db-reader/Manifest
index 668eacd1cc9f..48e10f9afd75 100644
--- a/dev-php/maxmind-db-reader/Manifest
+++ b/dev-php/maxmind-db-reader/Manifest
@@ -1 +1,2 @@
DIST MaxMind-DB-Reader-php-1.4.1.tar.gz 19667 BLAKE2B b397eb1bb7fa00c3382c7ee7c019c401d390c88d9bccd7742873445e95cb87d780ac17affe5cd1ec98e6f60d16660784dc5fdb188f8e4d2956df816397a9c251 SHA512 2407f3d1af10830078c9f5ba93ee74761084b06e630242eff0f707b98bdb78e6e87dabc999c36b29780ba9c8c38aec0225700005b66d95b3707bdc06875c6dd5
+DIST MaxMind-DB-Reader-php-1.6.0.tar.gz 20898 BLAKE2B cf6922bbd5b2c76fcb9b7a97299f0a73232686bf8facce39355f8a4cc55e98a4d8e64a51eae8427b5f14d6905d4cd85956effa5299cc493bd63708cf52ab30d0 SHA512 e8c0ccf2cfcedf7527b4e3f858d2ed0e70add60692fff4a65f08e5cb885516b7c2a3ceaa3c21713369cd8ffca2b671d764063236de1d729cfc5173f7d5dd4607
diff --git a/dev-php/maxmind-db-reader/maxmind-db-reader-1.6.0.ebuild b/dev-php/maxmind-db-reader/maxmind-db-reader-1.6.0.ebuild
new file mode 100644
index 000000000000..20d90c48bb65
--- /dev/null
+++ b/dev-php/maxmind-db-reader/maxmind-db-reader-1.6.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="MaxMind-DB-Reader-php"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+PHP_EXT_S="${S}/ext"
+PHP_EXT_NAME="maxminddb"
+PHP_EXT_OPTIONAL_USE="extension"
+
+USE_PHP="php7-2 php7-3 php7-4"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="PHP reader for the MaxMind database format"
+HOMEPAGE="https://github.com/maxmind/MaxMind-DB-Reader-php"
+SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="extension test"
+RESTRICT="!test? ( test )"
+
+DEPEND="extension? ( dev-libs/libmaxminddb )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ # We need to call eapply_user ourselves, because it may be skipped
+ # if either the "extension" USE flag is not set, or if the user's
+ # PHP_TARGETS is essentially empty. In the latter case, the eclass
+ # src_prepare does nothing. We only call the eclass phase conditionally
+ # because the correct version of e.g. "phpize" may not be there
+ # unless USE=extension is set.
+ if use extension ; then
+ php-ext-source-r3_src_prepare
+ else
+ default
+ fi
+}
+
+src_configure() {
+ # The eclass phase will try to run the ./configure script even if it
+ # doesn't exist (in contrast to the default src_configure), so we
+ # need to skip it if the eclass src_prepare (that creates said
+ # script) is not run.
+ use extension && php-ext-source-r3_src_configure
+}
+
+src_compile() {
+ # Avoids the same problem as in src_configure.
+ use extension && php-ext-source-r3_src_compile
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md
+ insinto /usr/share/php
+ doins -r src/MaxMind
+ insinto /usr/share/php/MaxMind/Db
+ doins autoload.php
+
+ use extension && php-ext-source-r3_src_install
+}
+
+src_test() {
+ # The PHP API has its own set of tests that isn't shipped with the
+ # release tarballs at the moment (github issues 55).
+ use extension && php-ext-source-r3_src_test
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/MaxMind/Db/."
+ elog "To use it in a script, require('MaxMind/Db/autoload.php'),"
+ elog "and then most of the examples in the documentation should"
+ elog "work without further modification."
+}