summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-09 12:46:57 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-09 12:46:57 -0500
commitc2d8f1d8c373967d2532ce31d51c24a1e9cfe188 (patch)
treef9d6a9b240ab12700d3ca6cfdf018500f852bf04 /dev-php/ming-php
parentsci-chemistry/votca-xtp: fix deps (bug #602174) (diff)
downloadgentoo-c2d8f1d8c373967d2532ce31d51c24a1e9cfe188.tar.gz
gentoo-c2d8f1d8c373967d2532ce31d51c24a1e9cfe188.tar.bz2
gentoo-c2d8f1d8c373967d2532ce31d51c24a1e9cfe188.zip
dev-php/ming-php: Version bump to match upstream
The code has not been modified from 0.4.5 (and in fact for several years) Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-php/ming-php')
-rw-r--r--dev-php/ming-php/Manifest1
-rw-r--r--dev-php/ming-php/ming-php-0.4.7.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/ming-php/Manifest b/dev-php/ming-php/Manifest
index 9ec5a39c82a6..ab75f7d7594f 100644
--- a/dev-php/ming-php/Manifest
+++ b/dev-php/ming-php/Manifest
@@ -1 +1,2 @@
DIST ming-0.4.5.tar.bz2 14234048 SHA256 82da089bdfc3a7fcb732dc11c11a35003ee270d5102d4043d61ea69834239aeb SHA512 9e5a2fb558841e72a072e2c29a0871dc7056ab57f1e6feca864b9b0961841334c4d2c6bc731bc4e043eb96b63fb946738cb1b8b54ef45679fcbf9bcf82adea31 WHIRLPOOL 2315adb1ed2b8878843ce5eef54f7c4386a69c809820aa4d2040fe4d94c0fa367cc57966a78e327f6a578c99b3ed4b1fa5d352106df9283f3b2d7f87a1178203
+DIST ming-0_4_7.tar.gz 14903570 SHA256 118aa1338dd74b34dd2cd22bce286ca0571e8b9aa433999646d1c0157ea9a7dc SHA512 232cf45daabd7b60203c9382aa6568455a42ddcd1bd60eec9bfe3f5e80376fcc9ff6304efbafca1ac8a504e2e167bc394e4902e0d067303d9582551461e09d3c WHIRLPOOL 075794f170e7f529ba79a66af4504745da786d7cd73e9673ffd4c48e943fbc8bf1f952f1cc0b0b7b0ca1e26a3bdb255feeaaeb675032616d2060c40f19d4dbdd
diff --git a/dev-php/ming-php/ming-php-0.4.7.ebuild b/dev-php/ming-php/ming-php-0.4.7.ebuild
new file mode 100644
index 000000000000..5b99a6b4ad9a
--- /dev/null
+++ b/dev-php/ming-php/ming-php-0.4.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME=ming
+MY_P="${PHP_EXT_NAME}-${PV//./_}"
+USE_PHP="php5-6"
+PHP_EXT_S="libming-${MY_P}/php_ext"
+inherit flag-o-matic php-ext-source-r3
+
+DESCRIPTION="PHP extension for the ming Flash movie generation library"
+HOMEPAGE="http://ming.sourceforge.net/"
+SRC_URI="https://github.com/libming/libming/archive/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/ming"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/libming-${MY_P}"
+
+src_prepare() {
+ local slot orig_s="${PHP_EXT_S}"
+ for slot in $(php_get_slots); do
+ cp "${FILESDIR}/php_ext-config.m4" "${WORKDIR}/${slot}/config.m4" || \
+ die "Failed to copy config.m4 to target"
+ rm "${WORKDIR}/${slot}/Makefile.am" || die "Failed to remove Makefile.am for ${slot}"
+ php_init_slot_env ${slot}
+ eapply -p0 "${FILESDIR}/ming-php-54.patch"
+ eapply_user
+ php-ext-source-r3_phpize
+ done
+}
+
+src_configure() {
+ # build is sensitive to -O3 (bug #297437)
+ replace-flags -O3 -O2
+
+ local PHP_EXT_EXTRA_ECONF="--with-ming=${S}"
+ php-ext-source-r3_src_configure
+}