summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-07 11:25:27 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-07 11:25:27 -0400
commitb276310aa80bd3d798aca15cf893368e1006819a (patch)
tree40a69a489ec3fccd72ecff3e2cd52bc3fc5ad80d /dev-php/pecl-dbase
parentmail-client/roundcube: New 1.3.0 ebuild (diff)
downloadgentoo-b276310aa80bd3d798aca15cf893368e1006819a.tar.gz
gentoo-b276310aa80bd3d798aca15cf893368e1006819a.tar.bz2
gentoo-b276310aa80bd3d798aca15cf893368e1006819a.zip
dev-php/pecl-dbase: New package wrt bug 418353
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php/pecl-dbase')
-rw-r--r--dev-php/pecl-dbase/Manifest2
-rw-r--r--dev-php/pecl-dbase/metadata.xml8
-rw-r--r--dev-php/pecl-dbase/pecl-dbase-5.1.1.ebuild44
-rw-r--r--dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1.ebuild44
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-php/pecl-dbase/Manifest b/dev-php/pecl-dbase/Manifest
new file mode 100644
index 000000000000..bc40edee62ab
--- /dev/null
+++ b/dev-php/pecl-dbase/Manifest
@@ -0,0 +1,2 @@
+DIST dbase-5.1.1.tgz 20751 SHA256 4474be791b302dc3ba34dc4f96cde626f81deb36a4d88dff5605bfbda8691439 SHA512 52dac3e253f88de898c43864e8aff62990b33eb770fb27534bd25896c3eb330ca05e0205a1f387296637e553cf6de16a3f7b3eff082e1403a56c60decfbce33f WHIRLPOOL f91bf2a4d47bf43a589255b179cca8872a81ac94975812328af7a00776256b5c1df957430f04c38b1000a8c224a9a3166b8d20f4b3e272c84ffad19126461f55
+DIST dbase-7.0.0beta1.tgz 16206 SHA256 bc84abddf2fe2e7121b3736bced9bcd30ed5d567ad1c917c26876c240cefbbf1 SHA512 623222e826509fa9b3f65353a66479fe4a5924de1b6dd4e73c106f2179f8af59740c758cf90ed8d0e9c61c31a7e5bef434cd858cde074f983b1dda69927442af WHIRLPOOL 4651e3742fa98b784e1d7efcae50348ee08a852e32be181e870787193dd4cc849cca628e8c10d199a577573b81e6ae582a0977ddcb7db2316ae2c0292549ff87
diff --git a/dev-php/pecl-dbase/metadata.xml b/dev-php/pecl-dbase/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/pecl-dbase/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-dbase/pecl-dbase-5.1.1.ebuild b/dev-php/pecl-dbase/pecl-dbase-5.1.1.ebuild
new file mode 100644
index 000000000000..03186ce8a0bd
--- /dev/null
+++ b/dev-php/pecl-dbase/pecl-dbase-5.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="dBase database file access functions"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+PDEPEND="
+php_targets_php7-0? ( dev-php/pecl-dbase:7[php_targets_php7-0] )
+php_targets_php7-1? ( dev-php/pecl-dbase:7[php_targets_php7-1] )
+"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php5-6 ; then
+ local PHP_EXT_ECONF_ARGS=( )
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1.ebuild b/dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1.ebuild
new file mode 100644
index 000000000000..f0480a3595b0
--- /dev/null
+++ b/dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
+# This allows us to depend on the other slot
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+# However, we only really build for 7.x; so redefine it here
+USE_PHP="php7-0 php7-1"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="dBase database file access functions"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-dbase:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ local PHP_EXT_ECONF_ARGS=( )
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}