summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-11-28 15:40:04 -0500
committerBrian Evans <grknight@gentoo.org>2016-11-28 15:57:25 -0500
commita241f29e3b7bc1a0d76f140de27d9df6d3863215 (patch)
treed14a742c4c9a6b98d93b0806347343d1600a6680 /dev-php/pecl-haru
parentdev-php/pecl-geoip: Revbump to drop PHP 5.5 support (diff)
downloadgentoo-a241f29e3b7bc1a0d76f140de27d9df6d3863215.tar.gz
gentoo-a241f29e3b7bc1a0d76f140de27d9df6d3863215.tar.bz2
gentoo-a241f29e3b7bc1a0d76f140de27d9df6d3863215.zip
dev-php/pecl-haru: Revbump to drop php 5.5 dependencies
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-haru')
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..54bd863defc9
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ local PHP_EXT_ECONF_ARGS=(
+ $(usex png '--with-png-dir=/usr' '')
+ $(usex zlib '--with-zlib-dir=/usr' '')
+ )
+
+ php-ext-source-r3_src_configure
+}