summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-07-15 12:29:07 -0400
committerBrian Evans <grknight@gentoo.org>2016-07-15 12:29:07 -0400
commitb7979406f569e62e7940ef177cc57dc3f070a1d8 (patch)
treefd8a94272a5ddfc133754b606c717d1c4bb5a294 /dev-php/pecl-memcached
parentdev-php/PEAR-HTML_Table: Version bump (diff)
downloadgentoo-b7979406f569e62e7940ef177cc57dc3f070a1d8.tar.gz
gentoo-b7979406f569e62e7940ef177cc57dc3f070a1d8.tar.bz2
gentoo-b7979406f569e62e7940ef177cc57dc3f070a1d8.zip
dev-php/pecl-memcached: Drop old version and unused patches
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/pecl-memcached')
-rw-r--r--dev-php/pecl-memcached/Manifest1
-rw-r--r--dev-php/pecl-memcached/files/libmc-1.09-fix.diff71
-rw-r--r--dev-php/pecl-memcached/files/pecl-memcached-1.0.2-php54_zend.patch15
-rw-r--r--dev-php/pecl-memcached/pecl-memcached-1.0.2-r2.ebuild40
4 files changed, 0 insertions, 127 deletions
diff --git a/dev-php/pecl-memcached/Manifest b/dev-php/pecl-memcached/Manifest
index 715e7a32bd87..d26a1e0a5ab6 100644
--- a/dev-php/pecl-memcached/Manifest
+++ b/dev-php/pecl-memcached/Manifest
@@ -1,2 +1 @@
-DIST memcached-1.0.2.tgz 22724 SHA256 16de77317e43b0a5bfd802c0bd2ef575adbad2093e8632d58738974e6cb14129 SHA512 02ccd76a540b86fbd392fcdb0bb632fa3d715b702ee90a10bd7a0330d9b181c7c4f1420bc60ffbcd1e0315fd602382a93b0d50aa8c7d1d9b9152868b60f595b3 WHIRLPOOL 674b1e9437b4cccce48810db5cb71961d88716c25e66b83e06307e718265a8de4053e3b260aa78f64a91c9f17779448f372217a85a4245c249957fbfcc32bec5
DIST memcached-2.2.0.tgz 70449 SHA256 17b9600f6d4c807f23a3f5c45fcd8775ca2e61d6eda70370af2bef4c6e159f58 SHA512 61207d3f8c11b0620dbcb20fb2ebb6d1fc10159a7e879ee91556a303c3dcdf3d2571e8dda5efcbed77ff779f5c9b226aa48800630b9e7781cd964126b848c356 WHIRLPOOL 1114a4c4371cfb42e3e4cb991980b32894f438abacf61c6da3dd6d9742c93e20df7691287c852c17dfe8261046227d73b1887c0b7b9c03a0e895a713005dc95a
diff --git a/dev-php/pecl-memcached/files/libmc-1.09-fix.diff b/dev-php/pecl-memcached/files/libmc-1.09-fix.diff
deleted file mode 100644
index 1b014dfd6422..000000000000
--- a/dev-php/pecl-memcached/files/libmc-1.09-fix.diff
+++ /dev/null
@@ -1,71 +0,0 @@
-This patch is fixes to compile with newer versions of libmemcached ported from the fork at:
-https://github.com/paravoid/php-memcached/commit/37069e18ad399a8cc03d5fe9757e1481814ecb44
-
-X-Ported-By: Allen Parker <infowolfe@gmail.com>
-Signed-off-by: Allen Parker <infowolfe@gmail.com>
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
-diff -Nurw memcached-2.1.0/php_memcached.c memcached-2.1.0-fixed/php_memcached.c
---- memcached-2.1.0-broken/php_memcached.c 2012-08-07 05:02:46.000000000 +0000
-+++ memcached-2.1.0/php_memcached.c 2013-12-16 06:14:17.420837278 +0000
-@@ -315,9 +315,15 @@
- static void php_memc_getDelayed_impl(INTERNAL_FUNCTION_PARAMETERS, zend_bool by_key);
- static memcached_return php_memc_do_cache_callback(zval *memc_obj, zend_fcall_info *fci, zend_fcall_info_cache *fcc, char *key, size_t key_len, zval *value TSRMLS_DC);
- static int php_memc_do_result_callback(zval *memc_obj, zend_fcall_info *fci, zend_fcall_info_cache *fcc, memcached_result_st *result TSRMLS_DC);
-+#if defined(LIBMEMCACHED_VERSION_HEX) && LIBMEMCACHED_VERSION_HEX >= 0x01000009
-+static memcached_return php_memc_do_serverlist_callback(const memcached_st *ptr, const memcached_instance_st *instance, void *in_context);
-+static memcached_return php_memc_do_stats_callback(const memcached_st *ptr, const memcached_instance_st *instance, void *in_context);
-+static memcached_return php_memc_do_version_callback(const memcached_st *ptr, const memcached_instance_st *instance, void *in_context);
-+#else
- static memcached_return php_memc_do_serverlist_callback(const memcached_st *ptr, memcached_server_instance_st instance, void *in_context);
- static memcached_return php_memc_do_stats_callback(const memcached_st *ptr, memcached_server_instance_st instance, void *in_context);
- static memcached_return php_memc_do_version_callback(const memcached_st *ptr, memcached_server_instance_st instance, void *in_context);
-+#endif
- static void php_memc_destroy(struct memc_obj *m_obj, zend_bool persistent TSRMLS_DC);
-
- /****************************************
-@@ -1855,7 +1861,7 @@
- zval **z_host, **z_port, **z_weight = NULL;
- uint32_t weight = 0;
- int entry_size, i = 0;
-- memcached_server_st *list = NULL;
-+ memcached_server_list_st list = NULL;
- memcached_return status;
- MEMC_METHOD_INIT_VARS;
-
-@@ -2573,7 +2579,11 @@
- /* }}} */
-
- /* {{{ internal API functions */
-+#if defined(LIBMEMCACHED_VERSION_HEX) && LIBMEMCACHED_VERSION_HEX >= 0x01000009
-+static memcached_return php_memc_do_serverlist_callback(const memcached_st *ptr, const memcached_instance_st *instance, void *in_context)
-+#else
- static memcached_return php_memc_do_serverlist_callback(const memcached_st *ptr, memcached_server_instance_st instance, void *in_context)
-+#endif
- {
- struct callbackContext* context = (struct callbackContext*) in_context;
- zval *array;
-@@ -2590,7 +2600,11 @@
- return MEMCACHED_SUCCESS;
- }
-
-+#if defined(LIBMEMCACHED_VERSION_HEX) && LIBMEMCACHED_VERSION_HEX >= 0x01000009
-+static memcached_return php_memc_do_stats_callback(const memcached_st *ptr, const memcached_instance_st *instance, void *in_context)
-+#else
- static memcached_return php_memc_do_stats_callback(const memcached_st *ptr, memcached_server_instance_st instance, void *in_context)
-+#endif
- {
- char *hostport = NULL;
- int hostport_len;
-@@ -2634,7 +2648,11 @@
- return MEMCACHED_SUCCESS;
- }
-
-+#if defined(LIBMEMCACHED_VERSION_HEX) && LIBMEMCACHED_VERSION_HEX >= 0x01000009
-+static memcached_return php_memc_do_version_callback(const memcached_st *ptr, const memcached_instance_st *instance, void *in_context)
-+#else
- static memcached_return php_memc_do_version_callback(const memcached_st *ptr, memcached_server_instance_st instance, void *in_context)
-+#endif
- {
- char *hostport = NULL;
- char version[16];
diff --git a/dev-php/pecl-memcached/files/pecl-memcached-1.0.2-php54_zend.patch b/dev-php/pecl-memcached/files/pecl-memcached-1.0.2-php54_zend.patch
deleted file mode 100644
index 22d550f29972..000000000000
--- a/dev-php/pecl-memcached/files/pecl-memcached-1.0.2-php54_zend.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/php_memcached.c 1970-01-01 04:13:08.000000000 -0500
-+++ b/php_memcached.c 2015-02-16 20:46:34.849201777 -0500
-@@ -1862,8 +1862,11 @@
-
- i_obj = ecalloc(1, sizeof(*i_obj));
- zend_object_std_init( &i_obj->zo, ce TSRMLS_CC );
-+#if PHP_VERSION_ID < 50399
- zend_hash_copy(i_obj->zo.properties, &ce->default_properties, (copy_ctor_func_t) zval_add_ref, (void *) &tmp, sizeof(zval *));
--
-+#else
-+ object_properties_init((zend_object*) &(i_obj->zo), ce);
-+#endif
- i_obj->compression = 1;
-
- retval.handle = zend_objects_store_put(i_obj, (zend_objects_store_dtor_t)zend_objects_destroy_object, (zend_objects_free_object_storage_t)php_memc_free_storage, NULL TSRMLS_CC);
diff --git a/dev-php/pecl-memcached/pecl-memcached-1.0.2-r2.ebuild b/dev-php/pecl-memcached/pecl-memcached-1.0.2-r2.ebuild
deleted file mode 100644
index c3891c8543c6..000000000000
--- a/dev-php/pecl-memcached/pecl-memcached-1.0.2-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PHP_EXT_NAME="memcached"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="README"
-
-USE_PHP="php5-5 php5-4"
-
-inherit php-ext-pecl-r2
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="PHP extension for interfacing with memcached via libmemcached library"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE="+session"
-
-DEPEND=">=dev-libs/libmemcached-0.38 sys-libs/zlib
- dev-lang/php:*[session?]"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- local slot orig_s="${PHP_EXT_S}"
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- epatch "${FILESDIR}/${P}-php54_zend.patch"
- done
- php-ext-source-r2_src_prepare
-}
-
-src_configure() {
- my_conf="--enable-memcached
- --with-zlib-dir=/usr
- $(use_enable session memcached-session)"
- php-ext-source-r2_src_configure
-}