summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-06 16:06:37 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-06 16:07:59 -0500
commitf447013440c937ba4a37472a05762b2f8f03a1a5 (patch)
treee05e636065c80ba90af34d76e1a148f7b9ad229b /dev-php/pecl-spl_types
parentdev-php/pecl-sphinx: Drop old (diff)
downloadgentoo-f447013440c937ba4a37472a05762b2f8f03a1a5.tar.gz
gentoo-f447013440c937ba4a37472a05762b2f8f03a1a5.tar.bz2
gentoo-f447013440c937ba4a37472a05762b2f8f03a1a5.zip
dev-php/pecl-spl_types: Revbump to remove php 5.4 and 5.5 support
No PHP 7 support exists officially. A fork at https://github.com/esminis/php_pecl_spl_types seems to have ported to 7, but testing is needed. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-spl_types')
-rw-r--r--dev-php/pecl-spl_types/pecl-spl_types-0.4.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/pecl-spl_types/pecl-spl_types-0.4.0-r2.ebuild b/dev-php/pecl-spl_types/pecl-spl_types-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..627747a45b94
--- /dev/null
+++ b/dev-php/pecl-spl_types/pecl-spl_types-0.4.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="spl_types"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_PKG="SPL_Types"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Standard PHP library types add-on"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"