summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-06-19 13:19:47 -0400
committerBrian Evans <grknight@gentoo.org>2019-06-19 13:19:47 -0400
commitf57ba45625fd92e45a2afbdd1eb4d188cd265a69 (patch)
tree7c6d2833b1249a936b2ca7236e1e56f73e9d5912 /dev-php/pecl-stomp
parentsys-kernel/gentoo-sources: Linux patch 5.1.12 (diff)
downloadgentoo-f57ba45625fd92e45a2afbdd1eb4d188cd265a69.tar.gz
gentoo-f57ba45625fd92e45a2afbdd1eb4d188cd265a69.tar.bz2
gentoo-f57ba45625fd92e45a2afbdd1eb4d188cd265a69.zip
dev-php/pecl-stomp: Fix build error finding OpenSSL
Closes: https://bugs.gentoo.org/688360 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-stomp')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
index d808c2c1b917..99522e6709c5 100644
--- a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
@@ -27,6 +27,8 @@ DEPEND="${DEPEND}
RDEPEND="${DEPEND}
php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+DEPEND="virtual/pkgconfig ${DEPEND}"
+
src_prepare() {
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
@@ -39,7 +41,7 @@ src_configure() {
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
local PHP_EXT_ECONF_ARGS=(
--enable-stomp
- --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ --with-openssl-dir=$(usex ssl yes no)
)
php-ext-source-r3_src_configure
fi