summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-06 14:30:13 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-06 14:30:52 -0400
commit7dc06485c634ac92a65774587f4032f99fb570e8 (patch)
tree1bd278f3755a0de984f97eb5ac2b5a409edbef7d /dev-php/pecl-xdiff
parentdev-lang/php: Version bump to 7.0.21 (diff)
downloadgentoo-7dc06485c634ac92a65774587f4032f99fb570e8.tar.gz
gentoo-7dc06485c634ac92a65774587f4032f99fb570e8.tar.bz2
gentoo-7dc06485c634ac92a65774587f4032f99fb570e8.zip
dev-php/pecl-xdiff: Revbumps to create slot and fix dependencies
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php/pecl-xdiff')
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r4.ebuild21
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild48
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r1.ebuild47
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-2.0.1.ebuild21
4 files changed, 95 insertions, 42 deletions
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r4.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r4.ebuild
deleted file mode 100644
index 1d0e0eb35ead..000000000000
--- a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r4.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="xdiff"
-PHP_EXT_PECL_PKG="xdiff"
-DOCS="README.API"
-
-USE_PHP="php5-6"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~x86 ~amd64"
-
-DESCRIPTION="PHP extension for generating diff files"
-LICENSE="PHP-3.01"
-SLOT="0"
-
-DEPEND="dev-libs/libxdiff"
-RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild
new file mode 100644
index 000000000000..4a9ca4d80720
--- /dev/null
+++ b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="xdiff"
+PHP_EXT_PECL_PKG="xdiff"
+DOCS=( README.API )
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension for generating diff files"
+LICENSE="PHP-3.01"
+SLOT="0"
+
+DEPEND="php_targets_php5-6? ( dev-libs/libxdiff )"
+RDEPEND="${DEPEND}"
+PDEPEND="
+php_targets_php7-0? ( dev-php/pecl-xdiff:7[php_targets_php7-0] )
+php_targets_php7-1? ( dev-php/pecl-xdiff:7[php_targets_php7-1] )
+"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php5-6 ; then
+ local PHP_EXT_ECONF_ARGS=()
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r1.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..d9e3a71d9e0f
--- /dev/null
+++ b/dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="xdiff"
+PHP_EXT_PECL_PKG="xdiff"
+DOCS=( README.API )
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension for generating diff files"
+LICENSE="PHP-3.01"
+SLOT="7"
+
+DEPEND="
+ php_targets_php7-0? ( dev-libs/libxdiff )
+ php_targets_php7-1? ( dev-libs/libxdiff )
+"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-xdiff:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ local PHP_EXT_ECONF_ARGS=()
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-2.0.1.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-2.0.1.ebuild
deleted file mode 100644
index 65799cfd4c08..000000000000
--- a/dev-php/pecl-xdiff/pecl-xdiff-2.0.1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="xdiff"
-PHP_EXT_PECL_PKG="xdiff"
-DOCS="README.API"
-
-USE_PHP="php7-0 php7-1"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~x86 ~amd64"
-
-DESCRIPTION="PHP extension for generating diff files"
-LICENSE="PHP-3.01"
-SLOT="0"
-
-DEPEND="dev-libs/libxdiff"
-RDEPEND="${DEPEND}"