summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-20 13:27:03 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-20 14:28:35 -0500
commit3210bba1e6c6214f2c43c9d5270d096da2acea71 (patch)
tree729974d88c03903fda3c29704903d618bbe457cc /dev-php/phing
parentdev-php/composer: Version bump (diff)
downloadgentoo-3210bba1e6c6214f2c43c9d5270d096da2acea71.tar.gz
gentoo-3210bba1e6c6214f2c43c9d5270d096da2acea71.tar.bz2
gentoo-3210bba1e6c6214f2c43c9d5270d096da2acea71.zip
dev-php/phing: Version bump for 2.16.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/phing')
-rw-r--r--dev-php/phing/Manifest1
-rw-r--r--dev-php/phing/phing-2.16.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-php/phing/Manifest b/dev-php/phing/Manifest
index 48cdc31ee650..926e2533c5da 100644
--- a/dev-php/phing/Manifest
+++ b/dev-php/phing/Manifest
@@ -1 +1,2 @@
DIST phing-2.16.0.tgz 4142331 BLAKE2B 567a7f0ac346c6c670342b74ea94d58e18ee306cd4f523f834c7cdfb8824a1d7e4d9c68c07da6d1b99fa6a0eeb120712ca36a28ef64314c6ed9056fcf633344d SHA512 f738d08a195d69c32a035dd3739e0cbc56946173dc31e8fdc8fc07664139b2b97832a6bbb527785e5dfe025530c364a1ed1075a0b77baecfc2395ec78549ba72
+DIST phing-2.16.1.tgz 4149013 BLAKE2B 266c124237d437361e9e18a42c9358fc18cfacfaa798a3a92a31858b7c1af847cde2cac43e0fcfe3759e8291639de9ec564f977fe00939316dbacdfd266e4e92 SHA512 e0832396dac9fbd43680f01acfa55f3ed2819726ace1db4ec9addf18c9c023c4f63143c6a63bbe1b16c2bd19dba54f503efdc77d772a3239bc8f9efe0ab375bb
diff --git a/dev-php/phing/phing-2.16.1.ebuild b/dev-php/phing/phing-2.16.1.ebuild
new file mode 100644
index 000000000000..5fda22fb029e
--- /dev/null
+++ b/dev-php/phing/phing-2.16.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://www.phing.info/get/${P}.tgz"
+
+LICENSE="FDL-1.3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples minimal zip"
+
+RDEPEND="dev-lang/php:*[cli,xml,xslt,zip?]
+ dev-php/symfony-yaml
+ !minimal? (
+ dev-php/PEAR-HTTP_Request2
+ dev-php/PEAR-PEAR_PackageFileManager
+ dev-php/PEAR-VersionControl_SVN
+ dev-php/PHP_CodeCoverage
+ dev-php/phpDocumentor
+ dev-php/phpmd
+ dev-php/phpunit
+ dev-php/simpletest
+ dev-php/xdebug
+ )"
+
+S="${WORKDIR}"
+
+src_install() {
+ dodoc CHANGELOG.md CREDITS.md README.md
+ dodoc -r docs/docbook5/en/output/hlhtml
+ use doc && dodoc -r docs/api
+ use examples && dodoc -r docs/example
+
+ # Install the executable (and the PHP file it wraps) outside of the
+ # PHP include directory, since nobody should be including it.
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ insinto "/usr/share/${PN}/bin"
+ doins "bin/${PN}.php"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ # Phing tries to get the version number from this file.
+ insinto "/usr/share/${PN}/etc"
+ doins etc/VERSION.TXT
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ # But install the library under /usr/share/php.
+ insinto "/usr/share/php"
+ doins -r "classes/${PN}"
+}