summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/phpunit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/phpunit')
-rw-r--r--dev-php/phpunit/Manifest2
-rw-r--r--dev-php/phpunit/metadata.xml5
-rw-r--r--dev-php/phpunit/phpunit-3.7.20.ebuild38
-rw-r--r--dev-php/phpunit/phpunit-4.3.1.ebuild38
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-php/phpunit/Manifest b/dev-php/phpunit/Manifest
new file mode 100644
index 000000000000..2e071e6bce6d
--- /dev/null
+++ b/dev-php/phpunit/Manifest
@@ -0,0 +1,2 @@
+DIST phpunit-3.7.20.phar 2769487 SHA256 7972291d498a425f7daaf0274eed45d8ba564b87da3250fc975e1af2b0d60602 SHA512 9263364087ad2f4870ce4d849c31b75c82799088809e444206b9e113e917d05923ece62264568ee5f2a6d7aeb04d75cbdc375ddd7825ceff16704431de5f68bf WHIRLPOOL 7e6399ccfe01f5e59bd14e243ee4fed760a40d36708aea8c1c5be08b2814125effb89f351f8ea0777d280d7a5557aadfe6142330bbc020d4c1159658cfc99baa
+DIST phpunit-4.3.1.phar 3324489 SHA256 1bac0c5f53bc04efa680bf9b3dcb35e804714eb8f497931ba81bdf08ae432c37 SHA512 de123e2301dc1d64e7401ceaec48c9458c3ab0dfc78faa488bed12c5b30b1367e1f9f6dfbbd5a07b427a56aad6d989f36a11b4642a0a843eed9c39e551be0490 WHIRLPOOL dbe5bed2251832c6c905b09c131bc2dc98de6247ef55077d9882c41a0b20b2e8b1c2489dbc0b3c1ed746f81c2b7163042e73790fff2b2ca78f8470875d77d88f
diff --git a/dev-php/phpunit/metadata.xml b/dev-php/phpunit/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/phpunit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/phpunit/phpunit-3.7.20.ebuild b/dev-php/phpunit/phpunit-3.7.20.ebuild
new file mode 100644
index 000000000000..4ee1173e689a
--- /dev/null
+++ b/dev-php/phpunit/phpunit-3.7.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+
+PHPUNIT_PHAR="${P}.phar"
+
+SRC_URI="http://dev.gentoo.org/~olemarkus/phpunit/${PHPUNIT_PHAR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+DEPEND="dev-lang/php:*[phar,xml]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/php/phpunit
+ insopts -m755
+ newins "${DISTDIR}"/${PHPUNIT_PHAR} phpunit.phar
+ dosym /usr/share/php/phpunit/phpunit.phar /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}
diff --git a/dev-php/phpunit/phpunit-4.3.1.ebuild b/dev-php/phpunit/phpunit-4.3.1.ebuild
new file mode 100644
index 000000000000..b1d013e47d0c
--- /dev/null
+++ b/dev-php/phpunit/phpunit-4.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+
+PHPUNIT_PHAR="${P}.phar"
+
+SRC_URI="https://phar.phpunit.de/${PHPUNIT_PHAR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+DEPEND="dev-lang/php:*[phar,xml]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/php/phpunit
+ insopts -m755
+ newins "${DISTDIR}"/${PHPUNIT_PHAR} phpunit.phar
+ dosym /usr/share/php/phpunit/phpunit.phar /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}