summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:22:51 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:21:32 -0500
commit31967bac591bf168aae2e4a94c7ed8d240dcd470 (patch)
tree62921938d265d52abf5d23603401e646b4546843 /dev-php/sebastian-exporter/sebastian-exporter-2.0.0.ebuild
parentdev-php/sebastian-global-state: New package for an unbundled phpunit (diff)
downloadgentoo-31967bac591bf168aae2e4a94c7ed8d240dcd470.tar.gz
gentoo-31967bac591bf168aae2e4a94c7ed8d240dcd470.tar.bz2
gentoo-31967bac591bf168aae2e4a94c7ed8d240dcd470.zip
dev-php/sebastian-exporter: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/sebastian-exporter/sebastian-exporter-2.0.0.ebuild')
-rw-r--r--dev-php/sebastian-exporter/sebastian-exporter-2.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-exporter/sebastian-exporter-2.0.0.ebuild b/dev-php/sebastian-exporter/sebastian-exporter-2.0.0.ebuild
new file mode 100644
index 000000000000..04f72fc63e7b
--- /dev/null
+++ b/dev-php/sebastian-exporter/sebastian-exporter-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Export PHP variables for visualization"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ =dev-php/sebastian-recursion-context-2*
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Exporter
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}