summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-10-31 09:13:56 -0400
committerBrian Evans <grknight@gentoo.org>2018-10-31 09:13:56 -0400
commit53e02f25bfcb02d2cf92ca6c7d58a2521f4e2700 (patch)
tree0b69980ba5a9f9fccd9393a47ba66cf3bc3dc48d /dev-php/tcpdf/tcpdf-6.2.25.ebuild
parentdev-php/PEAR-Net_SMTP: Version bump to 1.8.1 (diff)
downloadgentoo-53e02f25bfcb02d2cf92ca6c7d58a2521f4e2700.tar.gz
gentoo-53e02f25bfcb02d2cf92ca6c7d58a2521f4e2700.tar.bz2
gentoo-53e02f25bfcb02d2cf92ca6c7d58a2521f4e2700.zip
dev-php/tcpdf: Version bump for 6.2.25
Signed-off-by: Brian Evans <grknight@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-php/tcpdf/tcpdf-6.2.25.ebuild')
-rw-r--r--dev-php/tcpdf/tcpdf-6.2.25.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/tcpdf/tcpdf-6.2.25.ebuild b/dev-php/tcpdf/tcpdf-6.2.25.ebuild
new file mode 100644
index 000000000000..ff9b6ad05128
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-6.2.25.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="https://github.com/tecnickcom/TCPDF/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Main source is LGPL-3+, some included fonts have other licenses
+LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${P^^}"
+
+src_install() {
+ insinto /etc
+ doins config/tcpdf_config.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../../etc/tcpdf_config.php "/usr/share/php/${PN}/config/tcpdf_config.php"
+
+ exeinto "/usr/share/php/${PN}/tools"
+ doexe tools/tcpdf_addfont.php
+
+ insinto "/usr/share/php/${PN}"
+ doins tcpdf*.php
+ doins -r include fonts
+ DOCS=( CHANGELOG.TXT README.md )
+
+ use examples && HTML_DOCS=( examples )
+ einstalldocs
+}