summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-08-15 23:05:50 -0400
committerBrian Evans <grknight@gentoo.org>2015-08-15 23:05:50 -0400
commit47ce1158adf79906111a1994abcbb220f098eab2 (patch)
treea3fbf280eb72e47c5c6ebae6e7363ad348d0b883 /dev-php
parentdev-php/PEAR-XML_Util: Version bump (diff)
downloadgentoo-47ce1158adf79906111a1994abcbb220f098eab2.tar.gz
gentoo-47ce1158adf79906111a1994abcbb220f098eab2.tar.bz2
gentoo-47ce1158adf79906111a1994abcbb220f098eab2.zip
dev-php/{pear,PEAR-PEAR}: Version bump for PHP7 compatible version
This is being committed as masked because I expect many older PEAR packages to break with the new format. Further testing is required on all PEAR packages before unmasking. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pear/pear-1.10.0_alpha2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-php/pear/pear-1.10.0_alpha2.ebuild b/dev-php/pear/pear-1.10.0_alpha2.ebuild
new file mode 100644
index 000000000000..3405c1fc4970
--- /dev/null
+++ b/dev-php/pear/pear-1.10.0_alpha2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR - PHP Extension and Application Repository"
+HOMEPAGE="http://pear.php.net/"
+SRC_URI=""
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+S="${WORKDIR}"
+
+DEPEND=">=dev-lang/php-5.4:*
+ !<dev-php/PEAR-PEAR-1.8.1
+ ~dev-php/PEAR-PEAR-${PV}
+ >=dev-php/PEAR-Archive_Tar-1.4.0
+ >=dev-php/PEAR-Console_Getopt-1.4.1
+ >=dev-php/PEAR-Structures_Graph-1.1.0
+ >=dev-php/PEAR-XML_Util-1.3.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ :;
+}
+
+pkg_postinst() {
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ elog "Updating PEAR/PECL channels"
+ local pearchans="pear.php.net pecl.php.net components.ez.no
+ pear.propelorm.org pear.phing.info pear.symfony-project.com
+ pear.phpontrax.com pear.agavi.org"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}