summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-18 14:19:47 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-18 15:01:20 +0200
commitc2053c802f4ac24e6a5fcd9f8611f5bd2045f1a5 (patch)
tree5e89317df60276ae24320634b89b662c5d1bfba9 /dev-php
parentdev-php/symfony-console: bump to v2.8.50 (diff)
downloadgentoo-c2053c802f4ac24e6a5fcd9f8611f5bd2045f1a5.tar.gz
gentoo-c2053c802f4ac24e6a5fcd9f8611f5bd2045f1a5.tar.bz2
gentoo-c2053c802f4ac24e6a5fcd9f8611f5bd2045f1a5.zip
dev-php/symfony-event-dispatcher: bump to v2.8.50
security release Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/symfony-event-dispatcher/Manifest1
-rw-r--r--dev-php/symfony-event-dispatcher/symfony-event-dispatcher-2.8.50.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/symfony-event-dispatcher/Manifest b/dev-php/symfony-event-dispatcher/Manifest
index b51600e899c5..f050f1dad3dc 100644
--- a/dev-php/symfony-event-dispatcher/Manifest
+++ b/dev-php/symfony-event-dispatcher/Manifest
@@ -1 +1,2 @@
DIST symfony-event-dispatcher-2.1.0.tar.gz 10271 BLAKE2B 0fcb3fd95643a24ff31d4e60c31e801e488c323358dc723be95471dc01df9d052fc6cb19ce5401ba4512cc4e308fd149975f969cf89406b48d11e48ef6313ee1 SHA512 2430e0955322aa938635b34cfa151166218da51bcc7ac1ff52789fc16aef9eeaa5c504f9d03daa819f47652e5207703314c8695e5023369fe8edf88af06bc54b
+DIST symfony-event-dispatcher-2.8.50.tar.gz 15682 BLAKE2B dff817cc540074caabef6bbcd24fedee8bc377fbd688ead9d7a95df9987c79446bac630f806dfa190572a214393676042682b84bed58a6e0d5bb47d0dfd64986 SHA512 ecb5e17d5f0639c49fa35e9dc33d3b7d6a7792c95d9020ede9ceebe0de5e0192101607ac6f797e35a7ea5ced36231e616d76fe4f8ab74c0d42014782de590a35
diff --git a/dev-php/symfony-event-dispatcher/symfony-event-dispatcher-2.8.50.ebuild b/dev-php/symfony-event-dispatcher/symfony-event-dispatcher-2.8.50.ebuild
new file mode 100644
index 000000000000..eb7534b30305
--- /dev/null
+++ b/dev-php/symfony-event-dispatcher/symfony-event-dispatcher-2.8.50.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Symfony EventDispatcher Component"
+HOMEPAGE="https://github.com/symfony/event-dispatcher"
+SRC_URI="https://github.com/symfony/event-dispatcher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/symfony-dependency-injection-2.1.0"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+S="${WORKDIR}/event-dispatcher-${PV}"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/EventDispatcher"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}