summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-10-26 11:22:38 -0400
committerBrian Evans <grknight@gentoo.org>2016-10-26 11:22:38 -0400
commite4371eaa0c6350996e13c40756cd79ee3ebde89b (patch)
tree2c9462b9c9c8d9c183206f2d16e0e9b5c9d3e272 /dev-php
parentapp-emulation/docker-machine: remove old version 0.6.0 (diff)
downloadgentoo-e4371eaa0c6350996e13c40756cd79ee3ebde89b.tar.gz
gentoo-e4371eaa0c6350996e13c40756cd79ee3ebde89b.tar.bz2
gentoo-e4371eaa0c6350996e13c40756cd79ee3ebde89b.zip
dev-php/suhosin: Revbump to drop php 5.4 and 5.5 and EAPI6
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/suhosin/suhosin-0.9.38-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-php/suhosin/suhosin-0.9.38-r1.ebuild b/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
new file mode 100644
index 000000000000..a459bc7d6985
--- /dev/null
+++ b/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="no"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php5-6"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tar.gz"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[unicode] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-libcrypt.patch )
+DOCS=( CREDITS )
+
+src_install() {
+ php-ext-source-r3_src_install
+
+ local slot inifile
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ for inifile in $(php_slot_ini_files "${slot}") ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+ done
+}
+
+src_test() {
+ # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
+ # away from there in src_compile
+ for slot in `php_get_slots`; do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}