summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 14:13:24 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:07:48 +0200
commitf69172a20f0f24c60cb7e4acab6deb0402dbd881 (patch)
treeb5c96647848356fdc71f4d9dcc1e12b8dfa5b006 /dev-php
parentdev-php/pecl-xdiff: add PHP 7.3 support (diff)
downloadgentoo-f69172a20f0f24c60cb7e4acab6deb0402dbd881.tar.gz
gentoo-f69172a20f0f24c60cb7e4acab6deb0402dbd881.tar.bz2
gentoo-f69172a20f0f24c60cb7e4acab6deb0402dbd881.zip
dev-php/pecl-taint: bump to v2.0.5
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-taint/Manifest1
-rw-r--r--dev-php/pecl-taint/pecl-taint-2.0.5.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-php/pecl-taint/Manifest b/dev-php/pecl-taint/Manifest
index 9bb7a6a84d51..9cb8e8c1bc79 100644
--- a/dev-php/pecl-taint/Manifest
+++ b/dev-php/pecl-taint/Manifest
@@ -1,2 +1,3 @@
DIST taint-2.0.2.tgz 18550 BLAKE2B 70bd0425ab179c5313108a363b24310ed0c438a208ec15158d8c760cc8e2514b1031554827ced569c71cdb5109634463f75ca583fcc5cad56946947ab569fe25 SHA512 fe1375062f716a32b093942d173cf78024ed457fb5980ec8b50852ca922d8e15ec82696be2478cbbf8b9cd0620be0c2f88b18de55dec4dacec5be664b95c7108
DIST taint-2.0.4.tgz 18063 BLAKE2B 1ef1d44cc3dac5e25aeeac86b04d491e050174ed9ced1424729b29531917baf0776c8a6d78bc2d7b42bc768ba6744833d08c8df525d5fdd962b590b2d4c2a009 SHA512 d1c265e0fa4293b2aeb0f7413b852e85c6c321c67e31ff8fd51afefd157af4b733dfdf1452f50bcf3b05c1b5f26de9ebabe4ebe862657a05c4b6abc6770c2c7f
+DIST taint-2.0.5.tgz 18203 BLAKE2B 1e7d31f5a4eee810923420606892f2cd672d4fdcaf6decda1966d0ad44f779cf019a624c0f5971a44e8ceadf37159359f41ff52f523157eace26d7335405bad6 SHA512 625809e553d782dc6bb41b4dace1a32bf47157e3438430b3717e0ca692959625b293011220e47f95f4b484558e39454138b0760806fcd1e4ae42f608ab290b31
diff --git a/dev-php/pecl-taint/pecl-taint-2.0.5.ebuild b/dev-php/pecl-taint/pecl-taint-2.0.5.ebuild
new file mode 100644
index 000000000000..916d01e54270
--- /dev/null
+++ b/dev-php/pecl-taint/pecl-taint-2.0.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-1 php7-2 php7-3"
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Extension used for detecting XSS code (tainted strings)"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_postinst() {
+ elog 'To enable this extension, add'
+ elog ' taint.enable=1'
+ elog 'to /etc/php/<sapi>-<slot>/ext/taint.ini'
+}