summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-01 20:31:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-01 20:39:42 +0200
commitf06fc4ce29daa86dac3f5745134f423cb1fa7a21 (patch)
tree9838a116ab80f353efa0bae095d63524781ba5c7 /dev-python/ipdb
parentdev-lang/ruby: stable 2.6.7-r2 for hppa, bug #780498 (diff)
downloadgentoo-f06fc4ce29daa86dac3f5745134f423cb1fa7a21.tar.gz
gentoo-f06fc4ce29daa86dac3f5745134f423cb1fa7a21.tar.bz2
gentoo-f06fc4ce29daa86dac3f5745134f423cb1fa7a21.zip
dev-python/ipdb: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipdb')
-rw-r--r--dev-python/ipdb/ipdb-0.13.9-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ipdb/ipdb-0.13.9-r1.ebuild b/dev-python/ipdb/ipdb-0.13.9-r1.ebuild
new file mode 100644
index 000000000000..de8bc495eced
--- /dev/null
+++ b/dev-python/ipdb/ipdb-0.13.9-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="IPython-enabled pdb"
+HOMEPAGE="https://pypi.org/project/ipdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-python/ipython-7.17[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( HISTORY.txt )
+
+distutils_enable_tests unittest