summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-24 09:15:07 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:12:12 +0200
commit14b78d29deb6378aaee9120bd6087e4e9d8de6ab (patch)
treef4bb6eade9a4e0943b91a203e6b1f0300228f90b /dev-python/packaging/packaging-15.3.ebuild
parentsci-mathematics/mlpy: Fix typo (diff)
downloadgentoo-14b78d29deb6378aaee9120bd6087e4e9d8de6ab.tar.gz
gentoo-14b78d29deb6378aaee9120bd6087e4e9d8de6ab.tar.bz2
gentoo-14b78d29deb6378aaee9120bd6087e4e9d8de6ab.zip
dev-python/packaging: New package, ebuild written by me
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/packaging/packaging-15.3.ebuild')
-rw-r--r--dev-python/packaging/packaging-15.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-15.3.ebuild b/dev-python/packaging/packaging-15.3.ebuild
new file mode 100644
index 000000000000..45ee1b81fbda
--- /dev/null
+++ b/dev-python/packaging/packaging-15.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}