summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-14 15:48:20 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-22 21:32:08 +0200
commita06832d3de001d1d809c97400c6f1bb80e1187aa (patch)
tree4f8cd64843e7e0176d9a95877472117dee20d4ff /dev-python
parentwww-apps/karma-bin: 0.33 bump (diff)
downloadgentoo-a06832d3de001d1d809c97400c6f1bb80e1187aa.tar.gz
gentoo-a06832d3de001d1d809c97400c6f1bb80e1187aa.tar.bz2
gentoo-a06832d3de001d1d809c97400c6f1bb80e1187aa.zip
dev-python/fuse-python: version bump 0.3.1, EAPI 7, support Python3
Closes: https://bugs.gentoo.org/679534 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> [mgorny: removed pypy from PYTHON_COMPAT -- broken] Closes: https://github.com/gentoo/gentoo/pull/11362 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fuse-python/Manifest1
-rw-r--r--dev-python/fuse-python/fuse-python-0.3.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fuse-python/Manifest b/dev-python/fuse-python/Manifest
index 97bbd92d56c5..e5d1161cd644 100644
--- a/dev-python/fuse-python/Manifest
+++ b/dev-python/fuse-python/Manifest
@@ -1 +1,2 @@
DIST fuse-python-0.2.1.tar.gz 57833 BLAKE2B 99da322bfbfec193d2e4dfacedfd4e08a885152d1f1ceac19f49288be642c722d7776208dfdef5019b28a03cc00432e898744345041a7d615582c34668fb47a6 SHA512 f89c738352ca23e92b5c0222dde0a13bbee4d86432e9c339080203ed5bf4f885c42a0a3a252ed485f26b569d87e68dc0d78c55d8f7b2f3ce0cbac8afb251bdaa
+DIST fuse-python-0.3.1.tar.gz 45391 BLAKE2B c89d53bc99dc203cb56288ab36ebc6acfa1f5f7a21e10ff6aa12cb601a363d50b06b361ee17310c55a886592b13c789af4f5e86592b7f7af103fd56aefa6402e SHA512 88c01c1f9ca3cd9738711a621b782ec190adaf068a79fdea2c362d865c38fea73706dab48b8346b21502d6b4d404403a261f96e2570254809976a3018060e188
diff --git a/dev-python/fuse-python/fuse-python-0.3.1.ebuild b/dev-python/fuse-python/fuse-python-0.3.1.ebuild
new file mode 100644
index 000000000000..74f1bc069539
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/python-fuse-${PV}"