summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-27 17:39:45 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-27 18:25:25 -0600
commitdecb674b3958d2e5b1ad4f2b01fc7f2f03555f23 (patch)
tree772809a9041766daa285f33de28ce773a38f2c02 /dev-python
parentdev-python/flake8: add py37 support (diff)
downloadgentoo-decb674b3958d2e5b1ad4f2b01fc7f2f03555f23.tar.gz
gentoo-decb674b3958d2e5b1ad4f2b01fc7f2f03555f23.tar.bz2
gentoo-decb674b3958d2e5b1ad4f2b01fc7f2f03555f23.zip
dev-python/hacking: add py37 support
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hacking/Manifest1
-rw-r--r--dev-python/hacking/hacking-1.1.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hacking/Manifest b/dev-python/hacking/Manifest
index 2c8a5c6286c7..210dffc17212 100644
--- a/dev-python/hacking/Manifest
+++ b/dev-python/hacking/Manifest
@@ -2,3 +2,4 @@ DIST hacking-0.10.3.tar.gz 41119 BLAKE2B fe43b31f356c9469925bf43ff381c1e24d69769
DIST hacking-0.13.0.tar.gz 49171 BLAKE2B 2784f7303dc985ba8d0cc0c9d91dc76ff9b6bc02c1bbf1381e0803e753c2a4aa0560acead7e653616a2316bbd3ac073142cfc078dddea36b39b2c5e5bbef0f8e SHA512 ca3fe0bef1c6348ee9497c136d002b04c9f67a766192d88456b749ff860528a887636b1f3db23fec336749dbf3e5bb413a1effd2261e42929d5826e54336e314
DIST hacking-0.9.2.tar.gz 43956 BLAKE2B f4bad9ca0ffaaaf05d9f0b8536ccc72c51de4547de8d38ea31f9bae1ebbb52362d75fc286075b13631362fa00e3a7081db6a128584067896bf4daf7b32f4bfeb SHA512 76aa59b4cdfb8036d6471e35cba43d502de3a72edc3883a05822063cbb92eaa072cef3144d21ee82ac763c3385c65bc9dec4b66fda5a5a2090191ba5b6388d41
DIST hacking-0.9.6.tar.gz 43287 BLAKE2B e67090fe103849fd9cb4cd4ea36065d49500448cc291ffa2c36273095a2de4a704af2f3a926aef0ffe4aa4689ef7f810f317f0ed46e9c7143039ab776b04bfe5 SHA512 e4225754a85ff474b724130a0c3d6a6b9c480a953ea35a18833378cf2a5df4687819f510b50a95f42890cc69836033a8af933bc0a5a4e330ae94532bcee189b4
+DIST hacking-1.1.0.tar.gz 55620 BLAKE2B 6a6f30ef8a1eef3aa1b1b630dd43e1d2e9adff1623d8db19a545f186f60ce367e4b820582893e6444b7d58573b4a70a47a30cdc8d2ce1202666cf6e1b0e7456f SHA512 d326995976c04469c9d164ff31d02471346af715730d97fee23261988100156c4598ea8968cb483e8f386ee3f94a6bdffb5f67d8a7dfc238f4607fb7fe09e128
diff --git a/dev-python/hacking/hacking-1.1.0.ebuild b/dev-python/hacking/hacking-1.1.0.ebuild
new file mode 100644
index 000000000000..c78023fe0058
--- /dev/null
+++ b/dev-python/hacking/hacking-1.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/openstack-dev/hacking"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? (
+ >=dev-python/sphinx-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
+}
+
+python_test() {
+ testr init || die "testr init died"
+ testr run || die "testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/html/. )
+ distutils-r1_python_install_all
+}