summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-01-31 21:59:11 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-01-31 21:59:56 -0500
commite1a8b1ffc69692ff05e7dc0eb61c668f6e9c9c73 (patch)
tree49ba0b1eb4552f3f369db4e6c06238e8da4af1fb /dev-python
parentdev-python/pyotherside: adopt the package (diff)
downloadgentoo-e1a8b1ffc69692ff05e7dc0eb61c668f6e9c9c73.tar.gz
gentoo-e1a8b1ffc69692ff05e7dc0eb61c668f6e9c9c73.tar.bz2
gentoo-e1a8b1ffc69692ff05e7dc0eb61c668f6e9c9c73.zip
dev-python/pyotherside: bump to 1.5.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyotherside/Manifest1
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index 03372d135afa..5baf50970664 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1 +1,2 @@
DIST pyotherside-1.5.3.tar.gz 181811 BLAKE2B ce2b7c4b9490e3d30e0e8a3911907fe3ab5aa9f812d29cf4f633957d5ade5261ab7e3691751b0bc696459080089dfec0439b970ac7ad0bd36aa22eb0c9c87112 SHA512 ff6aa43e72f5492b18403559514e6fdf0d2cee0965556fcafe5fe394b654a7dd2fc3a7d64d4b8f9c0ebf95485821b77022407772b2414539f2ab287e1fb01e93
+DIST pyotherside-1.5.4.tar.gz 183745 BLAKE2B 3dad2486dbc3d2632999aff0a7a7af41f6fefcae011bd1dd92b491b4403bbd62adb9a8520af627d5f96644f4fb25e89ee8fb49277723d5f80521d2add984008d SHA512 feaf95e0c981a8fb8b3a57926f48f803584a371752e7f1d2f3c739ee220960df33ad4ca2a38322f3e56d4f8fde193bd7342105303d847b2f532937e8bf2c3b65
diff --git a/dev-python/pyotherside/pyotherside-1.5.4.ebuild b/dev-python/pyotherside/pyotherside-1.5.4.ebuild
new file mode 100644
index 000000000000..5950a1d6de85
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+# Requires active X display
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+
+ default
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}