summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-24 08:02:58 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:12:07 +0200
commitf81eb59cb2f0ccbfeaee653d2559a75f68f5fe7e (patch)
tree1368e61e11e97c72a26ac588444e790b924c0c8a /dev-python
parentdev-python/fixtures: Add pypy3 support (diff)
downloadgentoo-f81eb59cb2f0ccbfeaee653d2559a75f68f5fe7e.tar.gz
gentoo-f81eb59cb2f0ccbfeaee653d2559a75f68f5fe7e.tar.bz2
gentoo-f81eb59cb2f0ccbfeaee653d2559a75f68f5fe7e.zip
dev-python/lockfile: Add pypy3 support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/lockfile/lockfile-0.10.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/lockfile/lockfile-0.10.2.ebuild b/dev-python/lockfile/lockfile-0.10.2.ebuild
index 5e13652981d9..12c0bc08d4f8 100644
--- a/dev-python/lockfile/lockfile-0.10.2.ebuild
+++ b/dev-python/lockfile/lockfile-0.10.2.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -16,7 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="doc test"
-DEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=""