summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-06 11:52:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-06 12:24:41 +0200
commit3b11b1c8844f17fd7f46fa10256b355317dc3a46 (patch)
tree3485743d2ab92535f66734aae79382c94e83149f /dev-qt/qtlocation
parentmedia-libs/avidemux-plugins: Drop 2.6.20 (diff)
downloadgentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.tar.gz
gentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.tar.bz2
gentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.zip
dev-qt: Add Qt 5.12.4
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.12.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 82a0a43bca17..c2e756ac87f9 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1 +1,2 @@
DIST qtlocation-everywhere-src-5.12.3.tar.xz 5905856 BLAKE2B b52b9eaea77b4b429db90768d97c7f4d1319c7a860e864acb5afc5c35c0b2c7425afe64909751b2063bad747fe3aa6d899b39532a72065d4cd87935219a196f1 SHA512 91b21e5bc78b960f15c60ae02827cd35292ab1a5dd5a47488d25ce6758177f0ce15545aef3ff9bd1456c6fd84f65cb74d385b726239e2f0be66de0f6fb9a7082
+DIST qtlocation-everywhere-src-5.12.4.tar.xz 5909156 BLAKE2B 9afb944d4ca6b5566852309cd4d7709862a377b26d7293141e308f85b28641bef17e0a40ac094b8e94fa1ab2c4709415177bcaf104a7deebeac1f43845240224 SHA512 b03380feb2e6767dabb0a75f9234c52a9adc580d53b692c356b04293195f6cdd49d9c7e8eb91404b5a7e4c7507498078dd8f41de014330d35f0e99e034b8cf3a
diff --git a/dev-qt/qtlocation/qtlocation-5.12.4.ebuild b/dev-qt/qtlocation/qtlocation-5.12.4.ebuild
new file mode 100644
index 000000000000..e1e230b43e26
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.12.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}