summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-27 11:28:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-27 11:49:08 +0100
commit48b5dc400c7a3223c191fffac1753954e33c0e85 (patch)
treec6b2079dc0f72ae894f1a51b3c09605034b1e64c /dev-ros/genpy
parentdev-ros/genmsg: Add python 3.6 support (diff)
downloadgentoo-48b5dc400c7a3223c191fffac1753954e33c0e85.tar.gz
gentoo-48b5dc400c7a3223c191fffac1753954e33c0e85.tar.bz2
gentoo-48b5dc400c7a3223c191fffac1753954e33c0e85.zip
dev-ros/genpy: Add python 3.6 support and use standard ros-catkin.eclass src_test that works.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/genpy')
-rw-r--r--dev-ros/genpy/genpy-0.6.3.ebuild11
-rw-r--r--dev-ros/genpy/genpy-9999.ebuild11
2 files changed, 2 insertions, 20 deletions
diff --git a/dev-ros/genpy/genpy-0.6.3.ebuild b/dev-ros/genpy/genpy-0.6.3.ebuild
index b393c061a86b..bd9c12937753 100644
--- a/dev-ros/genpy/genpy-0.6.3.ebuild
+++ b/dev-ros/genpy/genpy-0.6.3.ebuild
@@ -6,7 +6,7 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros/genpy"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
inherit ros-catkin
@@ -23,12 +23,3 @@ DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
)
"
-
-python_test() {
- cd "${BUILD_DIR}"
- PYTHONPATH="${S}/src" nosetests --verbose -w "${S}/test" || die
-}
-
-src_test() {
- python_foreach_impl python_test
-}
diff --git a/dev-ros/genpy/genpy-9999.ebuild b/dev-ros/genpy/genpy-9999.ebuild
index b393c061a86b..bd9c12937753 100644
--- a/dev-ros/genpy/genpy-9999.ebuild
+++ b/dev-ros/genpy/genpy-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros/genpy"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
inherit ros-catkin
@@ -23,12 +23,3 @@ DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
)
"
-
-python_test() {
- cd "${BUILD_DIR}"
- PYTHONPATH="${S}/src" nosetests --verbose -w "${S}/test" || die
-}
-
-src_test() {
- python_foreach_impl python_test
-}