summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:14:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:14:50 +0200
commit6e45cd7754d48422d004bef8aad46c3c7f9734b0 (patch)
treee6f306afd5726111eb60e8282599e4e4086f9ed0 /dev-ros/rqt_action
parentdev-ros/rqt_msg: Initial import. Ebuild by me. (diff)
downloadgentoo-6e45cd7754d48422d004bef8aad46c3c7f9734b0.tar.gz
gentoo-6e45cd7754d48422d004bef8aad46c3c7f9734b0.tar.bz2
gentoo-6e45cd7754d48422d004bef8aad46c3c7f9734b0.zip
dev-ros/rqt_action: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_action')
-rw-r--r--dev-ros/rqt_action/Manifest1
-rw-r--r--dev-ros/rqt_action/metadata.xml5
-rw-r--r--dev-ros/rqt_action/rqt_action-0.3.12.ebuild24
-rw-r--r--dev-ros/rqt_action/rqt_action-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/rqt_action/Manifest b/dev-ros/rqt_action/Manifest
new file mode 100644
index 000000000000..a503bd56f8f3
--- /dev/null
+++ b/dev-ros/rqt_action/Manifest
@@ -0,0 +1 @@
+DIST rqt_common_plugins-0.3.12.tar.gz 231733 SHA256 602ceea814b152865cd55c140565ec82d72277d9de75b869ce9fd3ac5a17b749 SHA512 567fb85324a85ef935379762026f7f3b5fbe491f61d947c273c1d138286acb919a2f458151b7137587bddbe028617934a75695a165fc7e7e6fd4b4cd87247b7d WHIRLPOOL d49809544f3de32129233c562f643afeed599b4f42688050aa433023188467243409ac048464eac05fc06f9a20c9d8992946dc68db0b01d7bcfde585a65fc42b
diff --git a/dev-ros/rqt_action/metadata.xml b/dev-ros/rqt_action/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rqt_action/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rqt_action/rqt_action-0.3.12.ebuild b/dev-ros/rqt_action/rqt_action-0.3.12.ebuild
new file mode 100644
index 000000000000..f1b6cef67d46
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-0.3.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_action/rqt_action-9999.ebuild b/dev-ros/rqt_action/rqt_action-9999.ebuild
new file mode 100644
index 000000000000..f1b6cef67d46
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"