summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:32:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:32:37 +0200
commitaea494f4a8a81cc32c1d75fa95338cfdf003a1fd (patch)
tree8f4d583c5b90adfb3fdd2b870fe7e58a05bbc580 /dev-ros/rqt_nav_view
parentdev-ros/rqt_moveit: Initial import. Ebuild by me. (diff)
downloadgentoo-aea494f4a8a81cc32c1d75fa95338cfdf003a1fd.tar.gz
gentoo-aea494f4a8a81cc32c1d75fa95338cfdf003a1fd.tar.bz2
gentoo-aea494f4a8a81cc32c1d75fa95338cfdf003a1fd.zip
dev-ros/rqt_nav_view: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_nav_view')
-rw-r--r--dev-ros/rqt_nav_view/Manifest1
-rw-r--r--dev-ros/rqt_nav_view/metadata.xml5
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-0.4.2.ebuild30
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild30
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ros/rqt_nav_view/Manifest b/dev-ros/rqt_nav_view/Manifest
new file mode 100644
index 000000000000..3674c36f264e
--- /dev/null
+++ b/dev-ros/rqt_nav_view/Manifest
@@ -0,0 +1 @@
+DIST rqt_robot_plugins-0.4.2.tar.gz 2095395 SHA256 b074485352720226544c5036baa980962835129206b51871bf9a279979ff1d7e SHA512 31d9f2e9915e1c645cd9ac687aafb588171883da89ab27c5abdecf288b49e1d2a4530f3bc3202058dd3c833b4f7cad3f66e1da652f51252863473d380825213c WHIRLPOOL 889e0f7d55f190df5730b1424ad6bde2f4fe1757506d4e3499e1b06a97e41a075c2e0f9d1feea572e85492a8d138c8f0b09d520eed3b69743ca485f8de4a19d0
diff --git a/dev-ros/rqt_nav_view/metadata.xml b/dev-ros/rqt_nav_view/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rqt_nav_view/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-0.4.2.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-0.4.2.ebuild
new file mode 100644
index 000000000000..d3c2bb79e11c
--- /dev/null
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a gui for viewing navigation maps and paths"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild
new file mode 100644
index 000000000000..d3c2bb79e11c
--- /dev/null
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a gui for viewing navigation maps and paths"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"