summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-16 12:44:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-16 14:17:01 +0200
commit6a12716efeaf16d8da04df4790c2fa963cae19b4 (patch)
tree6e2a61b5b25bae6a7ebe882310e69399037e4a36 /dev-ros
parentdev-ros/kdl_conversions: Bump to 1.11.9. (diff)
downloadgentoo-6a12716efeaf16d8da04df4790c2fa963cae19b4.tar.gz
gentoo-6a12716efeaf16d8da04df4790c2fa963cae19b4.tar.bz2
gentoo-6a12716efeaf16d8da04df4790c2fa963cae19b4.zip
dev-ros/tf: Bump to 1.11.9.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf/Manifest1
-rw-r--r--dev-ros/tf/tf-1.11.9.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/tf/Manifest b/dev-ros/tf/Manifest
index ec1d90b81bdd..26bd803aaf53 100644
--- a/dev-ros/tf/Manifest
+++ b/dev-ros/tf/Manifest
@@ -1 +1,2 @@
DIST geometry-1.11.8.tar.gz 186749 SHA256 a372f2225d6d9625dadc9dee817281a22dfb4b4dc8fd129ee1fb9375993bfd88 SHA512 a7d1383635d96b8a95486cbb9d1fdfc762846cb6ecc41c0deef76cea4d9f9cde99c4b079527a25bc5ac559d4987fe7a4c3159e2435942bb3d4fb992da68e0e04 WHIRLPOOL e527970486796a67e1a8edfec0a8abfd562e36bbc9f38cf5a335bbd178f4dd68b067e526e4d308389e61852af8b17a59b0bb82a4faa3a45856c553ddd228fe3b
+DIST geometry-1.11.9.tar.gz 185525 SHA256 8c8e20d28d352b3ccb227ca7da39a1dddc051cf8309f90a46d6b0c7b2e398d33 SHA512 de775da483d1bcca05bcc0f05dc358e1e11e4ba9845f446f5810ca2e835e75ed7202ff7c43a0d7433f9db4298930af32715f2ab2689e0f22c9d8ac10a73cc97c WHIRLPOOL 52587f970b097b23970a136807449196362c37b071ac6766b362e30ddfe5d5f582d8d6c9f5de67b914f95d4ad82eaf6872eb7f930884053f3231ad990e34fbcd
diff --git a/dev-ros/tf/tf-1.11.9.ebuild b/dev-ros/tf/tf-1.11.9.ebuild
new file mode 100644
index 000000000000..9fbd6e2ea2c0
--- /dev/null
+++ b/dev-ros/tf/tf-1.11.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/angles
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"