summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 16:15:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:40 +0200
commitcd42d97b9ec515aa8d218e7a59ad1f63e0bd4f8a (patch)
tree40d7fe38a68149d67890dd5cfbd8913742218274 /dev-ros
parentdev-ros/libmavconn: fix build with boost 1.70 (diff)
downloadgentoo-cd42d97b9ec515aa8d218e7a59ad1f63e0bd4f8a.tar.gz
gentoo-cd42d97b9ec515aa8d218e7a59ad1f63e0bd4f8a.tar.bz2
gentoo-cd42d97b9ec515aa8d218e7a59ad1f63e0bd4f8a.zip
dev-ros/camera_calibration_parsers: fix boost python detection
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/camera_calibration_parsers/files/boostpython.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-ros/camera_calibration_parsers/files/boostpython.patch b/dev-ros/camera_calibration_parsers/files/boostpython.patch
index 8e2b868ec452..02019d6458f7 100644
--- a/dev-ros/camera_calibration_parsers/files/boostpython.patch
+++ b/dev-ros/camera_calibration_parsers/files/boostpython.patch
@@ -14,7 +14,7 @@ Index: camera_calibration_parsers/CMakeLists.txt
-else()
- find_package(Boost REQUIRED COMPONENTS filesystem python3)
-endif()
-+find_package(Boost REQUIRED COMPONENTS filesystem python)
++find_package(Boost REQUIRED COMPONENTS filesystem python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
catkin_python_setup()