summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-09-03 07:17:29 +0200
committerHans de Graaff <graaff@gentoo.org>2015-09-04 07:01:48 +0200
commitcdda96f12ade1f0cbbad5acd68fd18c50c37226c (patch)
treeee4067d265cb1d181f2100959c6fb04b1fddc609 /dev-ruby/amq-protocol
parentnet-analyzer/wireshark: Version bump. (diff)
downloadgentoo-cdda96f12ade1f0cbbad5acd68fd18c50c37226c.tar.gz
gentoo-cdda96f12ade1f0cbbad5acd68fd18c50c37226c.tar.bz2
gentoo-cdda96f12ade1f0cbbad5acd68fd18c50c37226c.zip
dev-ruby/amq-protocol: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/amq-protocol')
-rw-r--r--dev-ruby/amq-protocol/Manifest1
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/Manifest b/dev-ruby/amq-protocol/Manifest
index cd4d2e77a545..5443b3621ed3 100644
--- a/dev-ruby/amq-protocol/Manifest
+++ b/dev-ruby/amq-protocol/Manifest
@@ -1 +1,2 @@
DIST amq-protocol-1.9.2.gem 43520 SHA256 79e018cb1a3522967525973ae04d40884620e8d4adca02afeb710f00643a84be SHA512 ea4553b337589589cc89b70e351722ec8af402bd560d73fd35ad41665424a6212e03e26ac86aace5d90f599c7fc2236686fbd83bd75c7023647d95163a2d8573 WHIRLPOOL 5fcfd806b8d84aa64b10bc160fe439dcdff2977b739e04ec23b8f86d94f7a5bee4b95d3688317096b0dcf9214a12921f4b0a4c93c9bd0f6ad3376a6199659189
+DIST amq-protocol-2.0.0.gem 43008 SHA256 13ffd60f8f41d986b522f4dabce1c9d97e248395998e358298d1dfe54943ef9b SHA512 d0bc3de546b4d618fb66ecee57691c948058f8c82fab6f5747a6122d56be39d36a5670df76e4ad23124cccc81c5d1ba2babe6dda02f070a6d306eb30a8ad7cc8 WHIRLPOOL c4c98f6892f35959f92c42b35aea51b90bc074942e30999c7f8bf4f13156148d917f2a6d35580654483f8495b2e8423cbe123c130865ea2e2ac173860e8347a9
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.0.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.0.0.ebuild
new file mode 100644
index 000000000000..e1517c879e37
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}