summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ast
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ast')
-rw-r--r--dev-ruby/ast/Manifest2
-rw-r--r--dev-ruby/ast/ast-2.0.0.ebuild32
-rw-r--r--dev-ruby/ast/ast-2.1.0.ebuild32
-rw-r--r--dev-ruby/ast/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/ast/Manifest b/dev-ruby/ast/Manifest
new file mode 100644
index 000000000000..f81892308eac
--- /dev/null
+++ b/dev-ruby/ast/Manifest
@@ -0,0 +1,2 @@
+DIST ast-2.0.0.gem 14336 SHA256 e8912628cabb49357e69f741b707b5b92c1be8be596e236589c4c44e6d453cd2 SHA512 dee0296c4d1bcad6454930778cadf0395b25a87b4c24d15a74d190739344c66bce3f08451868278fc9cea1a420e8548698342264edeccda76b793afabc5ebf6b WHIRLPOOL 3a8ea7c502324261628711ebeb2391045938aa7e95e1d18e235365f58ab89f407162787a7299df3e0a2c112c6943d40e407b38509f993bd627a8d7216e041b6b
+DIST ast-2.1.0.gem 14848 SHA256 f3066fd52ad2aa5731d5321ea609190deade4f2be251a3891d1cecdc1df74b80 SHA512 b60fb87ba204456dbb09ed6d747322555e415f5849d67dfb75624c4de2158b65038db7e4762ac6faf6c2b6854b0af8069b13e0b9c33b50eeaf69d5963588403a WHIRLPOOL eea8653a94d54bd1eef6f081b3197f728593f6f05e8e6632d0f4a672b35e123dd7276d250142ec5a6e222800ca8926ac60bf112f35e44c97464fa0fb3250bfb0
diff --git a/dev-ruby/ast/ast-2.0.0.ebuild b/dev-ruby/ast/ast-2.0.0.ebuild
new file mode 100644
index 000000000000..4972ae247f7f
--- /dev/null
+++ b/dev-ruby/ast/ast-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}
diff --git a/dev-ruby/ast/ast-2.1.0.ebuild b/dev-ruby/ast/ast-2.1.0.ebuild
new file mode 100644
index 000000000000..4972ae247f7f
--- /dev/null
+++ b/dev-ruby/ast/ast-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}
diff --git a/dev-ruby/ast/metadata.xml b/dev-ruby/ast/metadata.xml
new file mode 100644
index 000000000000..24ff8f28c2ef
--- /dev/null
+++ b/dev-ruby/ast/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">whitequark/ast</remote-id>
+ </upstream>
+</pkgmetadata>