summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/bluecloth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/Manifest1
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild53
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0-r2.ebuild54
-rw-r--r--dev-ruby/bluecloth/metadata.xml5
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-ruby/bluecloth/Manifest b/dev-ruby/bluecloth/Manifest
new file mode 100644
index 000000000000..9e87be8a996d
--- /dev/null
+++ b/dev-ruby/bluecloth/Manifest
@@ -0,0 +1 @@
+DIST bluecloth-2.2.0.gem 94208 SHA256 b30128433f6a83909b0cb52c3e001ee002ca8760d9b433ecc5ced308f7e703f9 SHA512 498ffc9eddd47ded1df5c60e8ae8647de1e0376c7787c42dad2450c15a237b01a734bd0a2742c56cb59831cddc5b35c88e954abc0a087fc803ce4890c07c2852 WHIRLPOOL d953b32ce79ef2d39bfba162bef30bd304c744f20a9d7cc81979b656d769624c33ae3b30141f1affc3729c11904e300ce1d9037e97cb6dbac7470c61da32b721
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..5e25756366be
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND+=" doc? ( dev-lang/perl )"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ dev-ruby/rake-compiler
+ test? (
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 compatibility
+ sed -i -e '1i $: << "."' Rakefile || die
+}
+
+all_ruby_compile() {
+ rake man/man1/bluecloth.1 || die
+
+ all_fakegem_compile
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}
+
+all_ruby_install() {
+ doman man/man1/bluecloth.1
+
+ all_fakegem_install
+}
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0-r2.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..0d4cb70ecba2
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND+=" doc? ( dev-lang/perl )"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/hoe
+ test? (
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 and 2.2.x compatibility
+ sed -i -e '1i $: << "."' \
+ -e 's/Config/RbConfig/' Rakefile || die
+}
+
+all_ruby_compile() {
+ rake man/man1/bluecloth.1 || die
+
+ all_fakegem_compile
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}
+
+all_ruby_install() {
+ doman man/man1/bluecloth.1
+
+ all_fakegem_install
+}
diff --git a/dev-ruby/bluecloth/metadata.xml b/dev-ruby/bluecloth/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/bluecloth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>