summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/capistrano
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/capistrano')
-rw-r--r--dev-ruby/capistrano/Manifest3
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5-r1.ebuild41
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild49
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5.ebuild39
-rw-r--r--dev-ruby/capistrano/capistrano-3.3.5.ebuild36
-rw-r--r--dev-ruby/capistrano/capistrano-3.4.0.ebuild35
-rw-r--r--dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch12
-rw-r--r--dev-ruby/capistrano/metadata.xml9
8 files changed, 224 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/Manifest b/dev-ruby/capistrano/Manifest
new file mode 100644
index 000000000000..d1e4444445d0
--- /dev/null
+++ b/dev-ruby/capistrano/Manifest
@@ -0,0 +1,3 @@
+DIST capistrano-2.15.5.gem 132096 SHA256 3eb22ec58176918f44a71126b9bb8a1a34ae4efb99835eb72e187d03916604aa SHA512 10168080c7481ec6fc6f918ac90a3b1ce8f2b36f77411375e33cc915b02d5196ab061ac47e767edd724c82cffd1c2ad0a23ba1f0519cf1f2aae5b429167b19ff WHIRLPOOL 452b5977e08762e0f01822734517010228fd3398e6d5e19041483dae9a7f6bfb3d4940b15a20c3a3cd30205f62563c919b3057294cd82ccb99cb96abefcb8136
+DIST capistrano-3.3.5.gem 47616 SHA256 f828e1f08e0aefd4f1737c55d12d0cf7c9ffe8a6c310686d1fa2b03ccfaf7a8b SHA512 91f92dd2f60da4117c39b60b4a3c473fab13f1af8266f54d01706cb92f357a25c5b57bcfc93e532dea0b9aef628c162ca045bfc48feb94fb50b795db09598569 WHIRLPOOL af73d8870855c552ea2d48f8ce591febdf5efd5bf32c3eda88cd2712c7f66c7d765e959bf586e23de5339a05be83ccdf443cccb443d396394f9b314e69447659
+DIST capistrano-3.4.0.gem 46080 SHA256 b3895b116f0254e8321b668929ece792a9f936416ce740490033cf97a47f87f7 SHA512 dff61bbf673b752d0126b5ba8bf0b1470c27dd0e10c81e7180ab58d0bc98cdfdd330450edfa10c09829f5e43db3a56dbc76080b6503d3f9c70c779a96a57c296 WHIRLPOOL 6ecdc6b12c46f45b79940b5fd42925d52cc447220d03510b3956d68bd6c448d862290d673eb864e73b54f6ccb855de6fd749ebea941d84c7ed35208a38e4efae
diff --git a/dev-ruby/capistrano/capistrano-2.15.5-r1.ebuild b/dev-ruby/capistrano/capistrano-2.15.5-r1.ebuild
new file mode 100644
index 000000000000..94041616dbec
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.15.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+RUBY_PATCHES=( ${P}-sudo-cleanup.patch )
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+ sed -i -e '/pry/ s:^:#:' -e '4igem "mocha", "~>0.12.0"' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}
diff --git a/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
new file mode 100644
index 000000000000..674482178060
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.14 )"
+
+RUBY_PATCHES=( ${P}-sudo-cleanup.patch )
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+ sed -i -e '/pry/ s:^:#:' -e '4igem "mocha", "~>0.14.0"' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper cap /usr/bin/cap-2 'gem "capistrano", "~>2.0"'
+}
diff --git a/dev-ruby/capistrano/capistrano-2.15.5.ebuild b/dev-ruby/capistrano/capistrano-2.15.5.ebuild
new file mode 100644
index 000000000000..47a05ee83874
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.15.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+ sed -i -e '/pry/ s:^:#:' -e '4igem "mocha", "~>0.12.0"' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}
diff --git a/dev-ruby/capistrano/capistrano-3.3.5.ebuild b/dev-ruby/capistrano/capistrano-3.3.5.ebuild
new file mode 100644
index 000000000000..dcc15d193249
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.3.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/capistrano-stats-1.1.0:1
+ >=dev-ruby/sshkit-1.3:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The 'deploy:restart' hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}
diff --git a/dev-ruby/capistrano/capistrano-3.4.0.ebuild b/dev-ruby/capistrano/capistrano-3.4.0.ebuild
new file mode 100644
index 000000000000..bb3d7e2055a4
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/sshkit-1.3:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The 'deploy:restart' hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}
diff --git a/dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch b/dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch
new file mode 100644
index 000000000000..cbe68a476fd4
--- /dev/null
+++ b/dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch
@@ -0,0 +1,12 @@
+diff -ur /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.15.5/lib/capistrano/recipes/deploy.rb ./lib/capistrano/recipes/deploy.rb
+--- ./lib/capistrano/recipes/deploy.rb 2014-08-13 15:11:31.423773610 +0200
++++ /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.15.5/lib/capistrano/recipes/deploy.rb 2014-05-04 11:40:39.000000000 +0200
+@@ -462,7 +462,7 @@
+ DESC
+ task :cleanup, :except => { :no_release => true } do
+ count = fetch(:keep_releases, 5).to_i
+- try_sudo "ls -1dt #{releases_path}/* | tail -n +#{count + 1} | #{try_sudo} xargs rm -rf"
++ run "ls -1dt #{releases_path}/* | tail -n +#{count + 1} | #{try_sudo} xargs rm -rf"
+ end
+
+ desc <<-DESC
diff --git a/dev-ruby/capistrano/metadata.xml b/dev-ruby/capistrano/metadata.xml
new file mode 100644
index 000000000000..dbb6fb764591
--- /dev/null
+++ b/dev-ruby/capistrano/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<longdescription>
+Capistrano is a utility and framework for executing commands in parallel on
+multiple remote machines, via SSH.
+</longdescription>
+</pkgmetadata>