summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-15 06:34:05 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-15 06:35:14 +0200
commit7dbe2fb9c997331b08dacc7a2a6049f3053aca86 (patch)
tree901457bcc88025ecc39e9a0a7e94a8a84c43385f /dev-ruby/certificate_authority
parentdev-ruby/aws-sdk: cleanup (diff)
downloadgentoo-7dbe2fb9c997331b08dacc7a2a6049f3053aca86.tar.gz
gentoo-7dbe2fb9c997331b08dacc7a2a6049f3053aca86.tar.bz2
gentoo-7dbe2fb9c997331b08dacc7a2a6049f3053aca86.zip
dev-ruby/certificate_authority: add ruby23 revision
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/certificate_authority')
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..d5d0f95887fe
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0.6:*"
+
+all_ruby_prepare() {
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}