summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-15 07:37:25 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-15 08:04:06 +0100
commit07b7db2717a3e9700bdb5d04e2f0e10363d1dd65 (patch)
tree26af6dc2468ca6dc5867782f1c3c1536c9d9cc2c /dev-ruby/classifier-reborn
parentsys-apps/i2c-tools: Version bump. (diff)
downloadgentoo-07b7db2717a3e9700bdb5d04e2f0e10363d1dd65.tar.gz
gentoo-07b7db2717a3e9700bdb5d04e2f0e10363d1dd65.tar.bz2
gentoo-07b7db2717a3e9700bdb5d04e2f0e10363d1dd65.zip
dev-ruby/classifier-reborn: add 2.2.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/classifier-reborn')
-rw-r--r--dev-ruby/classifier-reborn/Manifest1
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/classifier-reborn/Manifest b/dev-ruby/classifier-reborn/Manifest
index fa75ee7e5bce..2a0d9ae08d4b 100644
--- a/dev-ruby/classifier-reborn/Manifest
+++ b/dev-ruby/classifier-reborn/Manifest
@@ -1,2 +1,3 @@
DIST classifier-reborn-2.0.4.tar.gz 40653 BLAKE2B afbf45ac146e67873f5b90a8cc4383afd4ff4fd3f3956f9d3d0ad3096b66e80380b9670aae34f919331c5111e1195259fba98ba2c80b8c27332149c92612db8a SHA512 f89a075b61c1f36894cc57cba3943174c4414512e6f89dd2fa854126e38132239312f2b3464ffbd9b531d8f2987658fafa9cd8fe29d5f7ad8146984436deddd5
DIST classifier-reborn-2.1.0.tar.gz 42088 BLAKE2B 8a7ecf4d91f4dbe0ceff82c9b7d2839cfa9ea695cbdeca0c0752a1017a870bef178ccd65c43351ff85c4ff4e59e918627e9e18a840463ab7b3f5ef6fdb27fc23 SHA512 0c28128d1eaef8eeb168b372228a52c1bf9683aec3a670eb568fe709eba0b2b5f34ff48f89dd51283b3b560fba3f1908a62407ca8746ad5d74cfa57a03bc38f3
+DIST classifier-reborn-2.2.0.tar.gz 319010 BLAKE2B f4bd3259b9d6e324f3f0feb06dfd1c8736eaa8ae0f687e488b6e11b9cda8e6bf9e56a175c01dfb9352184da1a030d1330e22917c7bfdcb4242fa0102f6291940 SHA512 d299ce8f3b96de5c6194e816d880ebb895faaacdc2a19985166bdc3d9760242ec41d85f22167ea66e9afd743f5d91d63881da02882d1a412fc95a0c5db63d04c
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild
new file mode 100644
index 000000000000..81569b8aacd0
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl test"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/'\
+ -e 's/vector_serialize/vector/'\
+ -i lib/${PN}/lsi.rb || die
+ fi
+ # Comment out broken test
+ #sed -i -e "/assert 'Normal',/s/^/#/" test/bayes/bayesian_test.rb || die
+
+ sed -i -e '/reporters/I s:^:#:' -e '/pry/ s:^:#:' test/test_helper.rb || die
+}