summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-09-20 07:52:56 +0200
committerHans de Graaff <graaff@gentoo.org>2018-09-22 07:25:13 +0200
commitc171aa76f071519f81deb64fced5bf7985d8368a (patch)
tree1d5c298cc9a9cdf9b9a9ddfecdf3a145067cf5b5 /dev-ruby/cri/cri-2.15.1.ebuild
parentdev-ruby/cri: cleanup (diff)
downloadgentoo-c171aa76f071519f81deb64fced5bf7985d8368a.tar.gz
gentoo-c171aa76f071519f81deb64fced5bf7985d8368a.tar.bz2
gentoo-c171aa76f071519f81deb64fced5bf7985d8368a.zip
dev-ruby/cri: add 2.15.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-ruby/cri/cri-2.15.1.ebuild')
-rw-r--r--dev-ruby/cri/cri-2.15.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/cri/cri-2.15.1.ebuild b/dev-ruby/cri/cri-2.15.1.ebuild
new file mode 100644
index 000000000000..30952c0fb573
--- /dev/null
+++ b/dev-ruby/cri/cri-2.15.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Cri is a library for building easy-to-use commandline tools"
+HOMEPAGE="https://rubygems.org/gems/cri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/colored-1.2"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/yard dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -e '/coveralls/I s:^:#:' -i test/helper.rb || die
+ sed -i -e '/rubocop/ s:^:#:' \
+ -e '/RuboCop/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rake test_unit || die
+}