summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/fast-stemmer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/fast-stemmer')
-rw-r--r--dev-ruby/fast-stemmer/Manifest1
-rw-r--r--dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild36
-rw-r--r--dev-ruby/fast-stemmer/metadata.xml8
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/fast-stemmer/Manifest b/dev-ruby/fast-stemmer/Manifest
new file mode 100644
index 000000000000..d735ee8c5ff2
--- /dev/null
+++ b/dev-ruby/fast-stemmer/Manifest
@@ -0,0 +1 @@
+DIST fast-stemmer-1.0.2.gem 11776 SHA256 d0aa9fd9cfbca836a09d8abb122552ac8234130271a3b0da1cb077323d650819 SHA512 7a7a17c62ecc9ce6eaaed9d0783f161c53c5c6faa07b7b0577da5a46d4539bf3880f71e4e9097a489c045222738d0441c322fb5cef5e02a1483405f815a81b29 WHIRLPOOL 1434f094714778a478c2cdb144b4eedc2fc405fe289af4e5e6e4f7e9531c70bacca266cc4dcb2a2b7463f63c9ed959302a4a1ba2f36dc7937c7cdb4f0577211d
diff --git a/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild b/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..1d5fc6c017e2
--- /dev/null
+++ b/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Simple wrapper around multithreaded Porter stemming algorithm"
+HOMEPAGE="https://github.com/romanbsd/fast-stemmer"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ rm ext/Makefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/stemmer$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/fast_stemmer_test.rb || die
+}
diff --git a/dev-ruby/fast-stemmer/metadata.xml b/dev-ruby/fast-stemmer/metadata.xml
new file mode 100644
index 000000000000..5b995e056db6
--- /dev/null
+++ b/dev-ruby/fast-stemmer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">romanbsd/fast-stemmer</remote-id>
+ </upstream>
+</pkgmetadata>