summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-08 06:02:35 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-08 06:02:35 +0200
commit01467f2141b7dffa21de4b53e91c77d1c9cd8ada (patch)
tree15d0f3bee15a5eb7c16c2d9741acb92775f17534 /dev-ruby/httpclient
parentdev-ruby/yard: add missing dependency on redcloth (diff)
downloadgentoo-01467f2141b7dffa21de4b53e91c77d1c9cd8ada.tar.gz
gentoo-01467f2141b7dffa21de4b53e91c77d1c9cd8ada.tar.bz2
gentoo-01467f2141b7dffa21de4b53e91c77d1c9cd8ada.zip
dev-ruby/httpclient: cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/Manifest1
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.2.4.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index 07cd4277d6a6..80f53172771c 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -1,2 +1 @@
-DIST httpclient-2.8.2.4.tgz 462907 BLAKE2B 46886ff67c9d0d5b81189c975d4bbc732c8bcd328eef9a52b5b22b405e9b12c5a2bf45b876d97195044c699ca9389729acfc384932c7e6698d59770f92a3ee14 SHA512 c225f302e6bd1f08fc089c202d4d870999ae9ef4bf1df416fb7f06b1732f50b9a7c69a5b73f1ee2f963665d5d436c243830555f8d42c60ac536abbae72b693a5
DIST httpclient-2.8.3.tgz 464624 BLAKE2B ce8ed523a24acce219027a4f1985caf2b4dae29bdba038ca2397e5f4d4b36c90b35cedfb62faa7faf426c3ce8589906df7832968c81b64bc9100eff6f4fe9745 SHA512 b65b5adb97af069d7ff6b6f4cccd6a42c6d9c88b797e9495768fe1f36a6bd93defe50190edc201de5e39c4e306ba0bd17a8ff2f8eba4d636dacafa06c172967d
diff --git a/dev-ruby/httpclient/httpclient-2.8.2.4.ebuild b/dev-ruby/httpclient/httpclient-2.8.2.4.ebuild
deleted file mode 100644
index d8a71390738f..000000000000
--- a/dev-ruby/httpclient/httpclient-2.8.2.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="https://github.com/nahi/httpclient"
-SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="Ruby"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 ~arm ~hppa ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- !dev-ruby/http-access2"
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
-
- # Fix documentation task
- sed -i -e 's/README.txt/README.md/' Rakefile || die
-
- # Remove mandatory CI reports since we don't need this for testing.
- sed -i -e '/reporter/s:^:#:' Rakefile || die
-
- # Remove mandatory simplecov dependency
- sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
-
- # Comment out test requiring network access that makes assumptions
- # about the environment, bug 395155
- sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
-
- # Skip tests using rack-ntlm which is not packaged. Weirdly these
- # only fail on jruby.
- rm test/test_auth.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
-}