summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-05 07:08:35 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-05 07:36:15 +0200
commite995313bf591a0c0655967f89e24d18aa415bbc4 (patch)
tree6cd78c4ae119ba152f318effe4367d2cddae0f61 /dev-ruby/jmespath
parentapp-crypt/{acme,certbot,certbot-apache,certbot-nginx}: remanifest (diff)
downloadgentoo-e995313bf591a0c0655967f89e24d18aa415bbc4.tar.gz
gentoo-e995313bf591a0c0655967f89e24d18aa415bbc4.tar.bz2
gentoo-e995313bf591a0c0655967f89e24d18aa415bbc4.zip
dev-ruby/jmespath: add 1.4.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/jmespath')
-rw-r--r--dev-ruby/jmespath/Manifest1
-rw-r--r--dev-ruby/jmespath/jmespath-1.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/Manifest b/dev-ruby/jmespath/Manifest
index d46fe20b9ea9..4dc1a4916f0d 100644
--- a/dev-ruby/jmespath/Manifest
+++ b/dev-ruby/jmespath/Manifest
@@ -1 +1,2 @@
DIST jmespath-1.3.1.tar.gz 40363 BLAKE2B 516966f9457425658cbe73ae20850e2869d1ac22d000b8220ce58e9eb485ff1fc0f6cf676a2b9571267b69737de1770b2fddeeff88366b8617bf70be7abbd27a SHA512 31f2e4d3137f0f2a837522561860dcab9aa659a51724373509caf9eef9ce7c2bc784ff57e4a527994eb68dfb6f1d2103d31f19e36a31538f0889ef56800c7829
+DIST jmespath-1.4.0.tar.gz 40899 BLAKE2B 45e52f649950b00205af6010084e009a7327600971fdf84e0569498a031e9307876e412a4491fc176724667246fe9f81317a80dd7ff6c44b7e24a135af224e01 SHA512 2b3923a5c853c527ae10ed95da49e3f4888f80ec4eec18fcec2eff16698765e6e875575994ce2fa681977fb5329b122d95cab77fb80ead3548fc26fcbfb33859
diff --git a/dev-ruby/jmespath/jmespath-1.4.0.ebuild b/dev-ruby/jmespath/jmespath-1.4.0.ebuild
new file mode 100644
index 000000000000..60b99b077efc
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}