summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-17 07:46:03 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-17 07:46:03 +0200
commitb234cf68c15de46fd2d69cb2fba2a30dc0849b12 (patch)
tree6078d098ef331fd51ab540933d482bd98ed07180 /dev-ruby/jwt
parentdev-ruby/jwt: cleanup (diff)
downloadgentoo-b234cf68c15de46fd2d69cb2fba2a30dc0849b12.tar.gz
gentoo-b234cf68c15de46fd2d69cb2fba2a30dc0849b12.tar.bz2
gentoo-b234cf68c15de46fd2d69cb2fba2a30dc0849b12.zip
dev-ruby/jwt: add 1.5.5
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/jwt')
-rw-r--r--dev-ruby/jwt/Manifest1
-rw-r--r--dev-ruby/jwt/jwt-1.5.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/jwt/Manifest b/dev-ruby/jwt/Manifest
index 68fc075859e7..7ea7bf36009b 100644
--- a/dev-ruby/jwt/Manifest
+++ b/dev-ruby/jwt/Manifest
@@ -1 +1,2 @@
DIST jwt-1.5.4.tar.gz 22053 SHA256 90be9e8acf3ad12a109092faebc3a050ea51eeb358e51798da2098fba9335bc2 SHA512 c594e7152d89a0ace71acd425553302de81fea2542fa23fc3809d8edbafa7498ec6cec37f07d41ebd5dfaad2b190d53614cf7b0f1c50a82cebb55cbd74c8909e WHIRLPOOL 93cef43f8ed630e4c987c386ca748574b00cea3e82733771fc259b3fe4f064a20319f9115d84d10723d4c708c9680ad024e4f81c74c3f1b544b984cbedf92419
+DIST jwt-1.5.5.tar.gz 28392 SHA256 e093ba8ee77385ed5958ac19d3118bff8cc287bd2af431df99075a65b9b4961f SHA512 c6bf93f4a13bdc5f3f32af173196c7c73cde6ad210466b8cf1a2a0dfb7f387cc5618709e35b0142f58e5604b842c6bc431b181139be516659e36e599fa931d3e WHIRLPOOL cf922c6df8e832d535d73559de8026f0b845ed08f99505989683035fd569d13406904c58b6ede4a22bbb7770911a5799739fd1ec51a13f9d131e9e649f218a81
diff --git a/dev-ruby/jwt/jwt-1.5.5.ebuild b/dev-ruby/jwt/jwt-1.5.5.ebuild
new file mode 100644
index 000000000000..2ad959c21286
--- /dev/null
+++ b/dev-ruby/jwt/jwt-1.5.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.configure/,/^end/ s:^:#:' \
+ -e '/codeclimate/I s:^:#:' \
+ spec/spec_helper.rb || die
+}