summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-18 08:33:42 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-18 08:48:08 +0200
commit5b2d958c16e9c079253c788869f419b04ce4d00b (patch)
tree89ded206858c09ed68c62aab41dd5780aa027c60 /dev-ruby/pg
parentdev-ruby/sprockets-rails: fix tests with rack 2.0 installed (diff)
downloadgentoo-5b2d958c16e9c079253c788869f419b04ce4d00b.tar.gz
gentoo-5b2d958c16e9c079253c788869f419b04ce4d00b.tar.bz2
gentoo-5b2d958c16e9c079253c788869f419b04ce4d00b.zip
dev-ruby/pg: add ruby23 revision
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/pg-0.18.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/pg/pg-0.18.4-r1.ebuild b/dev-ruby/pg/pg-0.18.4-r1.ebuild
new file mode 100644
index 000000000000..d5c133c2ca79
--- /dev/null
+++ b/dev-ruby/pg/pg-0.18.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server,threads] )"
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ || ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/*$(get_libname) lib || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}