summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-21 11:16:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-21 11:16:27 -0500
commita60828facca898d71d90297f688159b2c5e435b6 (patch)
treecb0cabc9cc9fa09b07702f3ad4b52757925611ef /dev-ruby/puppetdb-termini
parentapp-admin/puppet-agent: 5.5.0 bup (diff)
downloadgentoo-a60828facca898d71d90297f688159b2c5e435b6.tar.gz
gentoo-a60828facca898d71d90297f688159b2c5e435b6.tar.bz2
gentoo-a60828facca898d71d90297f688159b2c5e435b6.zip
dev-ruby/puppetdb-termini: 5.2.1 bup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-5.2.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index d44717f4a937..cdf9cf04e7b9 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_5.0.1-1puppetlabs1_all.deb 18888 BLAKE2B 9d1aaea64459d8e22ab293237fd1c3c1047dab4eb926f039b742aafe751a9f6eef60cc4ad784cf10f95dbfe278175aa69c56ca09f069aba9c642ff26bbc8b823 SHA512 513155a86b23b52b30eea49da49562bf1fce513f1fc58d4c026a61542e4c197d4806cc51548ceaf98bb5a9b88a6b0166575852858f0c7144437372644d32f962
DIST puppetdb-termini_5.1.3-1xenial_all.deb 20458 BLAKE2B 1b8f4b26640cc06d0cd805bdc2900640de0b20d13e3137becf764340e71bd8b75944be5ad86573e7d78d89f69e08e3b9c3d2b2eab0d8110bf97beb34214ea0cc SHA512 37cfee272865fde1fa2bd8a66c6b64639df01ba34ba9b5903efed1d8b3c82c2658887f0dfe9e6b154f9b4cc16396d06ffdeab521d675864b259059fe53fe3304
+DIST puppetdb-termini_5.2.1-1xenial_all.deb 20538 BLAKE2B 718a13c8e18037f38fdfb88178c28f7de34e42d70c4bdee205561e133359db103b4f55218a5b64052ffbd259976ce237fa3d0cb247a7d3805e73332aa7782d4f SHA512 dd9c8bceb2e1a3ec0cecdffe7ddf33c6190f90470fafca6cb224b73d04197c855ff6aa298d9d2adfdb88ef0040a114ca0783b63cda7ce0f54865ca6f6fa2934a
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-5.2.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-5.2.1.ebuild
new file mode 100644
index 000000000000..ecc47a98cfa9
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-5.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/xenial/puppet5/${PN:0:1}/${PN}/${PN}_${PV}-1xenial_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}