summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-oci8
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-oci8')
-rw-r--r--dev-ruby/ruby-oci8/Manifest2
-rw-r--r--dev-ruby/ruby-oci8/metadata.xml14
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild40
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild40
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild40
5 files changed, 136 insertions, 0 deletions
diff --git a/dev-ruby/ruby-oci8/Manifest b/dev-ruby/ruby-oci8/Manifest
new file mode 100644
index 000000000000..666cd81fb346
--- /dev/null
+++ b/dev-ruby/ruby-oci8/Manifest
@@ -0,0 +1,2 @@
+DIST ruby-oci8-2.1.7.gem 231424 SHA256 6970edbed87a3f62db99a73f1584e615c572eb5818a9506161fbaff4e623c8c8 SHA512 7d08cba20c6fd1537e140c92cc5a6c7b169d1feb1a6c07a66c5569a6adf456943135935d47ded6cbf0c4a783d14d7877bb827e375c17a3b92dd5db0df8433d37 WHIRLPOOL 16228efb3057aebd82825c848dddef027f91f408f51d68d6d24f904eaedb49275b4969b78f190a0755ee531f0821ae8ece0ce845ad159a6d2b842a32b0d8c11b
+DIST ruby-oci8-2.1.8.gem 249856 SHA256 f5ab06e0312849b181e0b5e471f73b3070b9317ba289875f7ed44ee963b48f50 SHA512 897e5b86106b45e12bf359b8ed379a36a1c457daa1de9e7a8431f409ec25b12b20e30ed254a2bc77ab1abc0731f1c45e93860a36e0e6903c6fc7573a9ceeef9e WHIRLPOOL 7628ff11626619a82c02792d97ff66a2349af289d92fb52f928ff11c328a17dc8d1e02b16473028d0473f62d05617f07c30814030b32eb9908e52d49f4c259db
diff --git a/dev-ruby/ruby-oci8/metadata.xml b/dev-ruby/ruby-oci8/metadata.xml
new file mode 100644
index 000000000000..30f65d2fe748
--- /dev/null
+++ b/dev-ruby/ruby-oci8/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>troy@lump.net</email>
+ <name>Troy Bowman</name>
+ </maintainer>
+ <longdescription>Oracle Interface for Ruby, compatible with oracle 8, 9i, 10g and 11g.</longdescription>
+ <upstream>
+ <remote-id type="rubyforge">ruby-oci8</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild
new file mode 100644
index 000000000000..e33ea5ff53b5
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-db/oracle-instantclient-basic"
+DEPEND+=" dev-db/oracle-instantclient-basic"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild
new file mode 100644
index 000000000000..9f1ff025b0c2
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND+=" dev-db/oracle-instantclient-basic"
+DEPEND+=" dev-db/oracle-instantclient-basic"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild
new file mode 100644
index 000000000000..e33ea5ff53b5
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-db/oracle-instantclient-basic"
+DEPEND+=" dev-db/oracle-instantclient-basic"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}