summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-28 07:21:02 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-28 07:21:02 +0200
commitb3bf87e26130ca78ff280d591d86ceb7400a36e9 (patch)
treed803ade555df60db0e1c07dd87b5430832095265 /dev-ruby/ruby-progressbar
parentapp-misc/pax-utils: trivial fix for double prefix. ED -> D. (diff)
downloadgentoo-b3bf87e26130ca78ff280d591d86ceb7400a36e9.tar.gz
gentoo-b3bf87e26130ca78ff280d591d86ceb7400a36e9.tar.bz2
gentoo-b3bf87e26130ca78ff280d591d86ceb7400a36e9.zip
dev-ruby/ruby-progressbar: add 1.8.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest1
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index 0d645390a219..7cfe293ecdec 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1,2 +1,3 @@
DIST ruby-progressbar-1.4.2.gem 24064 SHA256 1285524b097446471bc60c4b756f9f8c4b527dd870eaf318e7d83380cde99fa7 SHA512 443fc015b2dcabc76c685f1529a39ffba289cb00c3cee3992ef240fb9822729f9049db4d85c58ee1ab6cc17927cb325044ea45a968c755a9b5ad93f7b9999fbd WHIRLPOOL 50bcbefce6fe3e1b05ad20476f67f9e610e5e91e5d9bc92a8ecc0ef5ab79233c16237c04f3782878855fae8115e556d53a0c6624d151fcd49bd58792aeb370f7
DIST ruby-progressbar-1.7.5.gem 21504 SHA256 71c754e2e3f26b87f307e360dee8f2267800b88327a7def0098d7e6cb752d643 SHA512 1a5cb4b8ca9a9669bdaa60fcf3f01bec347b4ac1aefe737a7c6014bf40166c72d74ab0f489638c12ffd5245cc2b0a19186f7ab440bd7629579bf00d5155a8741 WHIRLPOOL 13e05a761c10c6fbb87cfb11f83f18acae93daeec1e11306b432ee751427e0d95a56d63cd7528590242b3e5241d4de6eaef2ea1b9190a1c1196430f4828f5580
+DIST ruby-progressbar-1.8.1.gem 26112 SHA256 95ded755295440de814704970d7ccaf3cb259854534f03a03a6d05918f3eece3 SHA512 bded41f29ed3386b83b0c4fe208813de330cb6be527c4b91cbf436f44d0efe58cb717a783d104f32b697fe1d9b71eeec500c8a72a9a5b34fc416c86e7565bc01 WHIRLPOOL 3e2c00c55734819fab7eaf9e0b1666cc1ff7a733edf2d14260f4f5baf77d2d608db1473c76c45759a5d055ee5c59ef7fdbd7869964e00b4ef6ea23882bce2150
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
new file mode 100644
index 000000000000..48eaf0f033cf
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby20)
+ # Skip specs since rspectacular doesn't work with ruby 2.0:
+ # https://github.com/thekompanee/rspectacular/issues/4
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec spec || die
+ ;;
+ esac
+}