summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby_gntp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby_gntp')
-rw-r--r--dev-ruby/ruby_gntp/Manifest1
-rw-r--r--dev-ruby/ruby_gntp/metadata.xml8
-rw-r--r--dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/ruby_gntp/Manifest b/dev-ruby/ruby_gntp/Manifest
new file mode 100644
index 000000000000..fed583164745
--- /dev/null
+++ b/dev-ruby/ruby_gntp/Manifest
@@ -0,0 +1 @@
+DIST ruby_gntp-0.3.4.gem 10240 SHA256 7f427fd1752e8b78cc288088282ef8261b7e6896d8bb401ac047d6fb6b1d142e SHA512 876b728430183b273bf97a7e7b662c0614bcc21a3d1a7c4c07b2af9b1643c9a9bc96e92843e6118903d75d99b21c2faff0f27c22fbc8822db14560937e6a5dd8 WHIRLPOOL 07d1ea12b09c83016374ec7fbf000f2fa3bfdf086265b4c83fc0760df38288a1ed03a04dbd01ed961e55eb03c07b368ffd4f4a024f114552bd9eaed5ffccb0b9
diff --git a/dev-ruby/ruby_gntp/metadata.xml b/dev-ruby/ruby_gntp/metadata.xml
new file mode 100644
index 000000000000..1af421508a17
--- /dev/null
+++ b/dev-ruby/ruby_gntp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">snaka/ruby_gntp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
new file mode 100644
index 000000000000..8904b7698441
--- /dev/null
+++ b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for GNTP(Growl Notification Transport Protocol)"
+HOMEPAGE="https://github.com/snaka/ruby_gntp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rr )"
+
+all_ruby_prepare() {
+ mv test spec || die
+ sed -i -e "s/Spec::Runner/RSpec/" \
+ -e "s#\.\./lib/##"\
+ spec/ruby_gntp_spec.rb || die
+
+}