summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rubyzip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rubyzip')
-rw-r--r--dev-ruby/rubyzip/Manifest2
-rw-r--r--dev-ruby/rubyzip/metadata.xml8
-rw-r--r--dev-ruby/rubyzip/rubyzip-0.9.9-r1.ebuild33
-rw-r--r--dev-ruby/rubyzip/rubyzip-0.9.9-r2.ebuild33
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.1.7-r1.ebuild45
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.1.7.ebuild45
6 files changed, 166 insertions, 0 deletions
diff --git a/dev-ruby/rubyzip/Manifest b/dev-ruby/rubyzip/Manifest
new file mode 100644
index 000000000000..7aea45303cd4
--- /dev/null
+++ b/dev-ruby/rubyzip/Manifest
@@ -0,0 +1,2 @@
+DIST rubyzip-0.9.9-git.tgz 59030 SHA256 897cce8c2aec4fceff51b05e353b73d7d86567a0efa6bfd6e65274ba53a3da17 SHA512 2b2b035ab0da92ff09e1a916dd703c6b3c0ca423db4a5b4c12fbbdc6018c370532721447e71559382d089172fa4ce3463d9aa148c460a6a0a4ee2ccc9df2cadc WHIRLPOOL a51746c4234ad9f993426da44ae75ad36f40ec3292eac4a0410f3bdef9ee1093542ccee2c893967daccf806666af7121e253dd113e04aaf445f5e8a0c4bc183f
+DIST rubyzip-1.1.7-git.tgz 100467 SHA256 12f769a0fa804cf93cabdffec31a56c535a5ad5030a5ca53e09c8b99d245dcf7 SHA512 c59c0f9671e6ddfed26555d860bad1fc560a3428b676dd10e3890b0d08aa847b1b3b6d75865ed1d12850da7a4a59f2a26d3e30d517f92803a144487bbc04ace8 WHIRLPOOL 97ae089905b289236c4c532b771c3a3764963d314b3848526247312a8f62912faeaaf8622bf6da7771e86dbffcd98587f6c0f28ed0f1e84e9c76218977dff566
diff --git a/dev-ruby/rubyzip/metadata.xml b/dev-ruby/rubyzip/metadata.xml
new file mode 100644
index 000000000000..07203c4fad72
--- /dev/null
+++ b/dev-ruby/rubyzip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rubyzip/rubyzip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rubyzip/rubyzip-0.9.9-r1.ebuild b/dev-ruby/rubyzip/rubyzip-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..af01abca77ab
--- /dev/null
+++ b/dev-ruby/rubyzip/rubyzip-0.9.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library for reading and writing zip files"
+HOMEPAGE="https://github.com/aussiegeek/rubyzip"
+# Tests are not included in the gem.
+SRC_URI="https://github.com/aussiegeek/rubyzip/tarball/${PV} -> ${P}-git.tgz"
+RUBY_S="aussiegeek-rubyzip-*"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${DEPEND} test? ( app-arch/zip )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}
diff --git a/dev-ruby/rubyzip/rubyzip-0.9.9-r2.ebuild b/dev-ruby/rubyzip/rubyzip-0.9.9-r2.ebuild
new file mode 100644
index 000000000000..373b280ad359
--- /dev/null
+++ b/dev-ruby/rubyzip/rubyzip-0.9.9-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library for reading and writing zip files"
+HOMEPAGE="https://github.com/aussiegeek/rubyzip"
+# Tests are not included in the gem.
+SRC_URI="https://github.com/aussiegeek/rubyzip/tarball/${PV} -> ${P}-git.tgz"
+RUBY_S="aussiegeek-rubyzip-*"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${DEPEND} test? ( app-arch/zip )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}
diff --git a/dev-ruby/rubyzip/rubyzip-1.1.7-r1.ebuild b/dev-ruby/rubyzip/rubyzip-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..be349b4c1ed8
--- /dev/null
+++ b/dev-ruby/rubyzip/rubyzip-1.1.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library for reading and writing zip files"
+HOMEPAGE="https://github.com/rubyzip/rubyzip"
+# Tests are not included in the gem.
+SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="Ruby"
+SLOT="1"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${DEPEND} test? ( app-arch/zip )"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and coveralls
+ sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid dependency on bundler
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Fix hardcoded path to /tmp
+ sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
+}
diff --git a/dev-ruby/rubyzip/rubyzip-1.1.7.ebuild b/dev-ruby/rubyzip/rubyzip-1.1.7.ebuild
new file mode 100644
index 000000000000..d5cfaf17a864
--- /dev/null
+++ b/dev-ruby/rubyzip/rubyzip-1.1.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library for reading and writing zip files"
+HOMEPAGE="https://github.com/rubyzip/rubyzip"
+# Tests are not included in the gem.
+SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="Ruby"
+SLOT="1"
+KEYWORDS="amd64 hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${DEPEND} test? ( app-arch/zip )"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and coveralls
+ sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid dependency on bundler
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Fix hardcoded path to /tmp
+ sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
+}