summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-02-16 15:36:51 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2019-02-16 15:51:31 -0800
commit71f3f922a9829c223471d70168163df37fd802e8 (patch)
tree6bcf9a02f2ca79cd85b73d60d9e7dfda25fe3e99 /dev-ruby
parentdev-ruby/typhoeus: add missing test dependency on dev-ruby/dalli (diff)
downloadgentoo-71f3f922a9829c223471d70168163df37fd802e8.tar.gz
gentoo-71f3f922a9829c223471d70168163df37fd802e8.tar.bz2
gentoo-71f3f922a9829c223471d70168163df37fd802e8.zip
dev-ruby/typhoeus: add ruby25 to slot 0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/typhoeus/typhoeus-0.6.9-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/typhoeus/typhoeus-0.6.9-r1.ebuild b/dev-ruby/typhoeus/typhoeus-0.6.9-r1.ebuild
new file mode 100644
index 000000000000..5e09b760aef8
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-0.6.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="https://rubygems.org/gems/typhoeus/
+ https://github.com/typhoeus/typhoeus"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.7.1"
+
+ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}