summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-09-04 11:11:45 +0200
committerPacho Ramos <pacho@gentoo.org>2017-09-04 11:11:45 +0200
commit0c93bb73d329b767ad6dfe5c65c2b5ba001148e6 (patch)
treee14f671c3ffeba9c9be27183953e9dc79c62aa0f /dev-scheme
parentapp-admin/sudo: Added "sasl" USE flag (bug #620240). (diff)
downloadgentoo-0c93bb73d329b767ad6dfe5c65c2b5ba001148e6.tar.gz
gentoo-0c93bb73d329b767ad6dfe5c65c2b5ba001148e6.tar.bz2
gentoo-0c93bb73d329b767ad6dfe5c65c2b5ba001148e6.zip
Remove masked for removal packages
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/stalin/Manifest1
-rw-r--r--dev-scheme/stalin/metadata.xml18
-rw-r--r--dev-scheme/stalin/stalin-0.11.ebuild74
3 files changed, 0 insertions, 93 deletions
diff --git a/dev-scheme/stalin/Manifest b/dev-scheme/stalin/Manifest
deleted file mode 100644
index fa467aff9a29..000000000000
--- a/dev-scheme/stalin/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST stalin-0.11.tgz 5392735 SHA256 95eafb4fa870cb93f5d79b8935c42664cf54f227b2c7eacf7b55b06b33e1e3fe SHA512 c42dfd5e6240fb865adc6c6f20dec2ae5fae9273a7750f4919a9fabfe8f2cd533031ca977006bb700939b7e5c113700cffdbddbc816a535996ab012cecb62517 WHIRLPOOL 6b623bd1667deef1c7cda014845b2550eae7600001647e706e5a0bbaa2dbb2eae840adbd1f4483a201e8c1b347f50aefcf6a1d99bf53adffebdd10e5507885fa
diff --git a/dev-scheme/stalin/metadata.xml b/dev-scheme/stalin/metadata.xml
deleted file mode 100644
index 5808e9892bfa..000000000000
--- a/dev-scheme/stalin/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>pchrist@gentoo.org</email>
- <name>Panagiotis Christopoulos</name>
- </maintainer>
- <maintainer type="project">
- <email>scheme@gentoo.org</email>
- <name>Gentoo Scheme Project</name>
- </maintainer>
- <longdescription lang="en">
- Stalin is an aggressively optimizing Scheme compiler. It is the most
- highly optimizing Scheme compiler, and in fact one of the most highly
- optimizing compilers of any sort for any language. It was written by
- Jeffrey M. Siskind.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-scheme/stalin/stalin-0.11.ebuild b/dev-scheme/stalin/stalin-0.11.ebuild
deleted file mode 100644
index ffcb23bedec4..000000000000
--- a/dev-scheme/stalin/stalin-0.11.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="An aggressively optimizing Scheme compiler"
-HOMEPAGE="http://community.schemewiki.org/?Stalin"
-SRC_URI="ftp://ftp.ecn.purdue.edu/qobi/${P}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND="x11-libs/libX11"
-DEPEND="${RDEPEND}"
-
-RESTRICT="strip"
-
-src_prepare() {
- sed -i -e "s/-O3 -fomit-frame-pointer/${CFLAGS}/" makefile || die
-}
-
-src_compile() {
- ./build || die "Stalin's compilation failed"
-}
-
-src_test() {
- einfo "This may take REALLY much time and requires"
- einfo "possibly more than 2Gb of RAM+swap."
- cd benchmarks || die
- ./compile-and-run-stalin-old-benchmarks || die "old benchmarks failed"
- #./compile-and-run-stalin-bcl-benchmarks || die "bcl bechmarks failed"
- #./compile-and-run-stalin-fdlcc-benchmarks || die "fdlcc benchmarks failed"
-}
-
-src_install() {
- pushd include
- doheader gc.h gc_config_macros.h
- insinto /usr/lib/${PN}
- doins \
- libgc.a libstalin.a stalin stalin-architecture-name \
- stalin.architectures QobiScheme.sc xlib.sc xlib-original.sc \
- Scheme-to-C-compatibility.sc
- fperms 755 /usr/lib/${PN}/stalin /usr/lib/${PN}/stalin-architecture-name
- popd
-
- cat > stalin <<- EOF
- #!/bin/bash
-
- exec /usr/lib/stalin/stalin -I /usr/include/stalin \
- -I /usr/lib/stalin -copt -fno-strict-aliasing $@
-
- EOF
-
- dobin stalin
- doman stalin.1
- dodoc ANNOUNCEMENT MORE README
- pushd benchmarks
- sed -i -e 's/..\/stalin/stalin/' make-hello || die
- dodoc hello.sc make-hello
- popd
-}
-
-pkg_postinst() {
- elog "In ${ROOT}/usr/share/doc/${PF} you will find the make-hello and"
- elog "hello.sc files(compressed). If you put them in the same directory"
- elog "and run make.hello, it will produce a \"hello\" executable."
- elog "The \"make-hello\" file can be used as an example of how to use"
- elog "stalin to compile code and create efficient executables. "
- elog "man stalin , for documentation"
-}