summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-02-17 11:15:27 -0800
committerZac Medico <zmedico@gentoo.org>2018-02-17 11:17:43 -0800
commit524b128b840fcfd36dab6be7fac7b42a091557b5 (patch)
tree7f049b050f54fcb76b7b4cd21dd51ad687e545a9 /dev-util/bazel
parentmedia-sound/clementine: Fix lastfm paths (diff)
downloadgentoo-524b128b840fcfd36dab6be7fac7b42a091557b5.tar.gz
gentoo-524b128b840fcfd36dab6be7fac7b42a091557b5.tar.bz2
gentoo-524b128b840fcfd36dab6be7fac7b42a091557b5.zip
dev-util/bazel: version bump to 0.10.1
Closes: https://bugs.gentoo.org/646050 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.10.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index fbcd61ffe67f..d9990a083747 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -1,3 +1,4 @@
+DIST bazel-0.10.1-dist.zip 92973197 BLAKE2B a1d681407e2c72a57b3dcbb5e2afc49e59670be65da3d7d038dc3b8593bc0ab5b4a06c8dd8fc8a617a92eef2fc26a049b6de9a1eab0d05f31efb2fbeeb9ce711 SHA512 1894c951fd39a084011f89dd0d458e182525c2bfd6c80da071865e981e21a8c2b8363530ab53af18e6deae4a488744d6d2b7a5a4acf04715c2e26560a01df707
DIST bazel-0.4.5-dist.zip 101505017 BLAKE2B dcdad3e6aaf115486f90c8f04110c475513aa7e8080cc971de2f7aa8ba4d7b6b6239886892cce8d947a96f0bad4e4d43ca8c720c0d76b1cc7bfe7b8079cd5293 SHA512 bc70e379a9f6f962440d05d4a706959461690e28a943833e17d6e2b7e3cd7dd2344f329f72d833ec5104334a71764fde195e50b09a582ae7c1b89bd62822943b
DIST bazel-0.5.2-dist.zip 100003640 BLAKE2B b7adf3ac805001fa9950296ff6d6390a2a7c6e925abe83c278c34913e6d0927e51ac7ed55035b5275c8e9e2e814f5df338b3593db722be2bf789891024e6223e SHA512 2580b41a09d8e7766bf06ed55bca06f542a13fecf050b105829811d8a95e8f9a4395ebc8d3ce6436ecec8faab704afd608d71e2d368e51c668df3f766ca6e9c1
DIST bazel-0.5.4-dist.zip 100430507 BLAKE2B 11694bdc8acabe6958ffcf8a4befe084a0682e3b06935e0a2c8257c3e150cd686d31071b43c04a5a0972fe1bb940baaf68143147d353f115af350357de17ac85 SHA512 f13c003d1d27213e5a723878f488f02a77f1549b6c377db007d412e3db558ab1dfc4e7434c0a7634959d7f5447e71200bda7f99c16fe70661ea81e610c8089f5
diff --git a/dev-util/bazel/bazel-0.10.1.ebuild b/dev-util/bazel/bazel-0.10.1.ebuild
new file mode 100644
index 000000000000..5a238c7915f2
--- /dev/null
+++ b/dev-util/bazel/bazel-0.10.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/zip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ # F: fopen_wr
+ # S: deny
+ # P: /proc/self/setgroups
+ # A: /proc/self/setgroups
+ # R: /proc/24939/setgroups
+ # C: /usr/lib/systemd/systemd
+ addpredict /proc
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
+ mv bazel-bin/scripts/bazel-complete.bash output/ || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp output/bazel-complete.bash ${PN}
+ bashcomp_alias ${PN} ibazel
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ dodoc -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}